# CVE-2026-67314: axios before 1.18.0 Prototype Pollution via auth subfields

> Attackers can tamper with outbound HTTP requests by injecting Basic auth credentials if the application is already vulnerable to prototype pollution.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** CLEANSTART-2026-UQ32454, CVE-2026-68943, DEBIAN-CVE-2026-67314, ECHO-2457-771f-4c04, GHSA-xj6q-8x83-jv6g, MINI-29w6-p48f-rfvp, MINI-4jhc-4vxx-r2jj, MINI-5hvg-vp69-4w45, MINI-6hqc-v526-hxjc, MINI-6qrx-rrg8-86fc, MINI-84pj-fmpw-2vjw, MINI-fqhm-67xf-rv45, MINI-g6c4-mm9v-675m, MINI-hhvv-6p79-v28v, MINI-mr74-cwq6-ww54, MINI-q4h8-757g-6547, MINI-qc42-4qfv-357p, MINI-rg7v-hgpq-428h, MINI-x85f-6fpj-8xqf, MINI-xwp8-2j9c-fc68, ROOT-APP-NPM-CVE-2026-67314, ROOT-APP-NPM-GHSA-xj6q-8x83-jv6g, UBUNTU-CVE-2026-67314

## What is CVE-2026-67314?

CVE-2026-67314 is a medium-severity vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

axios versions >=1.15.2 and <1.18.0 contain prototype-pollution read-side gadgets in Basic auth subfield handling (lib/adapters/http.js and lib/helpers/resolveConfig.js). When an application is already affected by a separate prototype-pollution primitive and makes an axios request with an own auth object that omits the username and/or password properties, axios reads the inherited Object.prototype.username and Object.prototype.password values and uses them to construct an outbound 'Authorization: Basic ...' header. axios itself does not pollute prototypes. The practical impact is outbound request tampering: an attacker who controls the polluted prototype values can inject attacker-chosen Basic auth credentials or replace an existing Authorization header. Credential disclosure is only possible under additional application-specific conditions.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-67314?

2 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 1.15.2 | 1.18.0 |
| `axios` | npm | From 1.15.2 | 1.18.0 |

Products: Axios Axios.

## How do I fix CVE-2026-67314?

Upgrade axios to 1.18.0 or later.

## Is CVE-2026-67314 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67314 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67314 and fix it if it is affected.

What it is: CVE-2026-67314 is a medium-severity vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67314 exists.

Affected packages and fixed versions:
- axios (npm): affected from 1.15.2; fixed in 1.18.0
- axios (npm): affected from 1.15.2; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67314/ (Markdown: https://insights.sbomify.com/CVE-2026-67314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67314
- OSV: https://osv.dev/vulnerability/CVE-2026-67314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67314/
Summaries are generated and may contain mistakes; the official description above is the record.
