# CVE-2026-67315: axios 0.31.0 before 0.33.0 and 1.15.0 before 1.18.0 NO_PROXY Bypass via 0.0.0.0


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** CLEANSTART-2026-XM36205, CVE-2026-68946, DEBIAN-CVE-2026-67315, ECHO-dc66-a292-9d7e, GHSA-f4gw-2p7v-4548, MINI-3c6v-6x4v-xjhv, MINI-52ff-3r6g-x9cr, MINI-5gx4-fc96-295w, MINI-6cqm-v8x8-r2v8, MINI-7757-78c2-rphj, MINI-8g88-g5jw-8g89, MINI-cvph-r3fr-4r7g, MINI-g976-p468-7x5r, MINI-j8cx-4gh4-cp4g, MINI-m745-qcrx-48c8, MINI-mh6w-4f5w-mc24, MINI-q887-699m-63jx, MINI-qpvf-52q8-w4ff, MINI-vqwx-x6pm-h99m, MINI-wq8x-mcwx-j726, MINI-x94c-f2h9-vg5q, ROOT-APP-NPM-CVE-2026-67315, ROOT-APP-NPM-GHSA-f4gw-2p7v-4548, UBUNTU-CVE-2026-67315

## What is CVE-2026-67315?

CVE-2026-67315 is a medium-severity vulnerability in axios, published on 1 Aug 2026. 

### Official description

axios versions 0.31.0 before 0.33.0 and 1.15.0 before 1.18.0 fail to recognize 0.0.0.0 as a loopback address in shouldBypassProxy.js, allowing requests to 0.0.0.0 to bypass NO_PROXY rules. Attackers can supply 0.0.0.0 URLs to route requests through configured proxies, potentially exposing local services when the proxy can reach the destination.

Weakness: CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-67315?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 0.31.0 | 0.33.0 |
| `axios` | npm | From 0.31.0 | 0.33.0 |
| `axios` | npm | From 1.15.0 | 1.18.0 |
| `axios` | npm | From 1.15.0 | 1.18.0 |

Products: Axios Axios.

## How do I fix CVE-2026-67315?

Upgrade axios to a fixed version for your release line: 0.33.0 or 1.18.0.

## Is CVE-2026-67315 being exploited?

There is no known exploitation of CVE-2026-67315 in the wild and no public exploit code.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67315 and fix it if it is affected.

What it is: CVE-2026-67315 is a medium-severity vulnerability in axios, published on 1 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-67315 in the wild and no public exploit code.

Affected packages and fixed versions:
- axios (npm): affected from 0.31.0; fixed in 0.33.0
- axios (npm): affected from 0.31.0; fixed in 0.33.0
- axios (npm): affected from 1.15.0; fixed in 1.18.0
- axios (npm): affected from 1.15.0; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67315/ (Markdown: https://insights.sbomify.com/CVE-2026-67315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67315
- OSV: https://osv.dev/vulnerability/CVE-2026-67315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67315/
Summaries are generated and may contain mistakes; the official description above is the record.
