# CVE-2026-67316: axios before 1.18.0 Prototype Pollution via bodyless methods

> Prototype pollution in axios allows attackers to manipulate request construction, potentially sending unintended bodies or routing traffic through malicious proxies.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** CLEANSTART-2026-RH17623, CLSA-2026-1784943218, CLSA-2026-1784943302, CLSA-2026-1784943417, CLSA-2026-1785117469, CVE-2026-68944, DEBIAN-CVE-2026-67316, ECHO-49a7-d227-134a, GHSA-mmx7-hfxf-jppx, MINI-43xm-8cc5-mmm2, MINI-4mvm-pr53-456x, MINI-5vg7-2wfh-p44h, MINI-6mrx-gvv4-x3fh, MINI-774c-cg73-xf37, MINI-7jc7-f3vr-333f, MINI-88jc-vp4v-6m5w, MINI-949p-gqwj-whg9, MINI-9xx8-qwg7-rv56, MINI-cpwf-3986-cj77, MINI-gc5x-xgj8-vc9q, MINI-gggp-r84j-cmcw, MINI-h2ww-h5qf-q378, MINI-h5hg-8qrf-6w6q, MINI-jq74-m7r8-c9jg, MINI-m286-w958-86pc, MINI-p244-3w98-vmx3, MINI-p9rw-r72g-p2m8, MINI-pm8m-p6gg-4jxf, MINI-qhq2-phhg-69jr, MINI-r7hf-4w6x-7cr4, MINI-vrv9-87fw-gw84, MINI-w325-7q3q-hjhf, MINI-x3rx-5p7m-f6cw, MINI-xvwm-wq6j-j7ff, ROOT-APP-NPM-CVE-2026-67316, ROOT-APP-NPM-GHSA-mmx7-hfxf-jppx, UBUNTU-CVE-2026-67316

## What is CVE-2026-67316?

CVE-2026-67316 is a medium-severity unsafe deserialization vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

axios is vulnerable to read-side prototype-pollution gadgets that can alter request construction when Object.prototype has already been polluted by a separate vulnerability or dependency. In the bodyless method aliases (axios.get(), axios.delete(), axios.head(), axios.options()), inherited data is read via (config || {}).data before config normalization, causing an attacker-controlled body to be sent on requests that did not set one. Additional low-level paths, only reachable when calling exported adapters/helpers (e.g. lib/adapters/http.js, unsafe/helpers/resolveConfig.js) directly with plain configs and no own proxy or paramsSerializer, can inherit polluted proxy values (routing requests through an attacker-controlled proxy) or paramsSerializer values (attacker-controlled URL serialization). These low-level gadgets do not reproduce through normal high-level axios calls on 1.15.2+. The issue is fixed in axios 1.18.0 and 0.33.0.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-67316?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.33.0 |
| `axios` | npm | All versions | 0.33.0 |
| `axios` | npm | From 1.0.0 | 1.18.0 |
| `axios` | npm | From 1.0.0 | 1.18.0 |

Products: Axios Axios.

## How do I fix CVE-2026-67316?

Upgrade axios to a fixed version for your release line: 0.33.0 or 1.18.0.

## Is CVE-2026-67316 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67316 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67316 and fix it if it is affected.

What it is: CVE-2026-67316 is a medium-severity unsafe deserialization vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67316 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.33.0
- axios (npm): affected all versions; fixed in 0.33.0
- axios (npm): affected from 1.0.0; fixed in 1.18.0
- axios (npm): affected from 1.0.0; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67316/ (Markdown: https://insights.sbomify.com/CVE-2026-67316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67316
- OSV: https://osv.dev/vulnerability/CVE-2026-67316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67316/
Summaries are generated and may contain mistakes; the official description above is the record.
