# CVE-2026-67319: axios before 0.33.0 Prototype Pollution via nested option objects

> Attackers can inject credentials or alter query serialization in axios if prototype pollution exists elsewhere, requiring an upgrade to secure versions.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** CLEANSTART-2026-EZ79876, CLSA-2026-1787841237, CVE-2026-69123, DEBIAN-CVE-2026-67319, ECHO-1225-9205-2453, GHSA-7q8q-rj6j-mhjq, MINI-257w-4829-84vj, MINI-5p98-gfh6-vqq5, MINI-6hg9-35cp-2mww, MINI-7wmg-69q6-h34w, MINI-8m2v-p9g5-w773, MINI-9hc7-v8v9-57mf, MINI-c6wj-xvh7-pc2v, MINI-fp3r-5qj2-3xhw, MINI-gr5j-2r78-4wcm, MINI-h4mf-w6p8-hgjr, MINI-j3gm-fffg-xgg4, MINI-m97f-cmjh-pv88, MINI-mc9g-3vrh-j8mr, MINI-p33f-64h2-23q5, MINI-p4m4-cpj9-j3v8, MINI-pqqj-5qwq-33wv, MINI-q6h5-hf22-p26m, MINI-qwf3-528r-5rg3, MINI-r8vx-f8gp-4v4v, MINI-r9g9-qqh4-5ff5, MINI-rv2g-xc33-fg29, MINI-v696-76x5-m3q2, MINI-v6qj-gxjx-4h7h, MINI-w6w4-qf9m-7pq8, MINI-whg4-32vp-m79m, ROOT-APP-NPM-CVE-2026-67319, ROOT-APP-NPM-GHSA-7q8q-rj6j-mhjq, UBUNTU-CVE-2026-67319

## What is CVE-2026-67319?

CVE-2026-67319 is a medium-severity unsafe deserialization vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

axios before 0.33.0 (and 1.x before 1.18.0) can consume inherited properties from nested request option objects when the JavaScript process's Object.prototype has already been polluted by another component. While the top-level merged config uses a null prototype, nested plain objects such as auth and paramsSerializer are cloned into ordinary objects and read without own-property checks. When an application passes placeholder nested objects such as auth: {} or paramsSerializer: {}, inherited username/password values can cause silent injection of an Authorization: Basic header, and inherited encode/serialize values can alter query-string serialization (full serializer replacement requires a function-valued pollution primitive). This is exploitable only in the presence of pre-existing prototype pollution.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-67319?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 0.8.0 | 0.33.0 |
| `axios` | npm | From 0.8.0 | 0.33.0 |
| `axios` | npm | From 1.0.0 | 1.18.0 |
| `axios` | npm | From 1.0.0 | 1.18.0 |

Products: Axios Axios.

## How do I fix CVE-2026-67319?

Upgrade axios to a fixed version for your release line: 0.33.0 or 1.18.0.

## Is CVE-2026-67319 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67319 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67319 and fix it if it is affected.

What it is: CVE-2026-67319 is a medium-severity unsafe deserialization vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67319 exists.

Affected packages and fixed versions:
- axios (npm): affected from 0.8.0; fixed in 0.33.0
- axios (npm): affected from 0.8.0; fixed in 0.33.0
- axios (npm): affected from 1.0.0; fixed in 1.18.0
- axios (npm): affected from 1.0.0; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67319/ (Markdown: https://insights.sbomify.com/CVE-2026-67319/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67319
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67319
- OSV: https://osv.dev/vulnerability/CVE-2026-67319

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67319/
Summaries are generated and may contain mistakes; the official description above is the record.
