# CVE-2026-67320: axios before 0.33.0 Prototype Pollution via Node HTTP adapter

> Prototype pollution in axios Node HTTP adapter allows attackers to route requests through malicious proxies, exposing sensitive headers and data.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** CLEANSTART-2026-RK13390, CVE-2026-69124, DEBIAN-CVE-2026-67320, ECHO-7df6-530c-722c, GHSA-gcfj-64vw-6mp9, MINI-3fc3-x7qc-x2q5, MINI-3rm4-3h6h-58q2, MINI-555r-r7g3-c49g, MINI-69rj-gfxc-mfm3, MINI-8446-4225-3q27, MINI-9h7w-w7vg-pcq4, MINI-frvr-rpvv-g4cc, MINI-jr3j-v96f-99vq, MINI-mmxv-hpr4-r6xv, MINI-pm8w-pwm3-p5f8, MINI-qmqg-7p62-58gr, MINI-vq95-6xq6-6jxw, MINI-vrhv-4g2m-mxgf, MINI-w7j9-5pm2-9f4f, MINI-wgxc-cj9h-77g8, ROOT-APP-NPM-CVE-2026-67320, ROOT-APP-NPM-GHSA-gcfj-64vw-6mp9, UBUNTU-CVE-2026-67320

## What is CVE-2026-67320?

CVE-2026-67320 is a high-severity unsafe deserialization vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

axios in a Node.js deployment using the HTTP adapter can route requests through an attacker-controlled proxy. axios hardens merged request configuration by creating a null-prototype object, but request interceptors run after the merge; a common immutable interceptor pattern such as {...config} or Object.assign({}, config) converts the hardened config back into a regular object. axios then dispatches that object without re-hardening it, and the Node HTTP adapter reads config.proxy through the prototype chain. If an attacker can pollute Object.prototype.proxy, affected requests can be routed through an attacker-controlled proxy. For plaintext HTTP requests, the proxy can observe Authorization headers, Basic auth from config.auth, method, absolute URL, Host, and request body, and can return its own response. This does not establish browser impact or HTTPS header/body disclosure under normal TLS validation. Affected versions are >=0.31.1 (fixed in 0.33.0) and >=1.15.2 (fixed in 1.18.0).

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-67320?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 0.31.1 | 0.33.0 |
| `axios` | npm | From 0.31.1 | 0.33.0 |
| `axios` | npm | From 1.15.2 | 1.18.0 |
| `axios` | npm | From 1.15.2 | 1.18.0 |

Products: Axios Axios.

## How do I fix CVE-2026-67320?

Upgrade axios to a fixed version for your release line: 0.33.0 or 1.18.0.

## Is CVE-2026-67320 being exploited?

There is no known exploitation of CVE-2026-67320 in the wild and no public exploit code.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)
- [CVE-2026-44486](https://insights.sbomify.com/CVE-2026-44486/): Axios: Proxy-Authorization header leaks to redirect target when proxy is re-evaluated to direct connection (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67320 and fix it if it is affected.

What it is: CVE-2026-67320 is a high-severity unsafe deserialization vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67320 in the wild and no public exploit code.

Affected packages and fixed versions:
- axios (npm): affected from 0.31.1; fixed in 0.33.0
- axios (npm): affected from 0.31.1; fixed in 0.33.0
- axios (npm): affected from 1.15.2; fixed in 1.18.0
- axios (npm): affected from 1.15.2; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67320/ (Markdown: https://insights.sbomify.com/CVE-2026-67320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67320
- OSV: https://osv.dev/vulnerability/CVE-2026-67320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67320/
Summaries are generated and may contain mistakes; the official description above is the record.
