# CVE-2026-67321: axios 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 Denial of Service via maxDepth bypass

> Attackers can cause denial of service in applications using axios by triggering a RangeError during form serialization with crafted object keys.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** CLEANSTART-2026-CF21287, CVE-2026-69125, DEBIAN-CVE-2026-67321, ECHO-09eb-e0fe-e165, GHSA-hcpx-6fm6-wx23, MINI-2v5w-63cw-v25w, MINI-3x9g-m8r5-rj69, MINI-6jp9-fmq8-5f3c, MINI-6w66-6h79-5x57, MINI-6xwg-7v7r-m49v, MINI-72hr-hq74-58pj, MINI-739w-w5fw-q4m4, MINI-8qm9-p783-jj66, MINI-cw66-6cgq-gmhf, MINI-h346-v24m-7jh4, MINI-jr82-9h4x-fm4g, MINI-pvhh-g9wg-v3x6, MINI-rmx9-xff2-6m99, MINI-w257-h7gc-q632, MINI-wv72-3mq4-j34x, MINI-x744-w8pp-xqhr, ROOT-APP-NPM-CVE-2026-67321, ROOT-APP-NPM-GHSA-hcpx-6fm6-wx23, UBUNTU-CVE-2026-67321

## What is CVE-2026-67321?

CVE-2026-67321 is a medium-severity denial of service vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

axios versions 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 contain an incomplete depth-limit bypass in toFormData.js when serializing objects with top-level keys ending in '{}'. Attackers who control object keys and nested values passed to axios form or parameter serialization can trigger a RangeError from JSON.stringify, causing denial of service in the affected request path.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-67321?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 0.31.1 | 0.33.0 |
| `axios` | npm | From 0.31.1 | 0.33.0 |
| `axios` | npm | From 1.15.1 | 1.18.0 |
| `axios` | npm | From 1.15.1 | 1.18.0 |

Products: Axios Axios.

## How do I fix CVE-2026-67321?

Upgrade axios to a fixed version for your release line: 0.33.0 or 1.18.0.

## Is CVE-2026-67321 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67321 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67321 and fix it if it is affected.

What it is: CVE-2026-67321 is a medium-severity denial of service vulnerability in axios, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67321 exists.

Affected packages and fixed versions:
- axios (npm): affected from 0.31.1; fixed in 0.33.0
- axios (npm): affected from 0.31.1; fixed in 0.33.0
- axios (npm): affected from 1.15.1; fixed in 1.18.0
- axios (npm): affected from 1.15.1; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67321/ (Markdown: https://insights.sbomify.com/CVE-2026-67321/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67321
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67321
- OSV: https://osv.dev/vulnerability/CVE-2026-67321

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67321/
Summaries are generated and may contain mistakes; the official description above is the record.
