# CVE-2026-67322: GitPython before 3.1.52 Environment Variable Exfiltration via clone_from

> Attackers can exfiltrate environment variables by crafting malicious clone URLs, exposing secrets like API keys to remote hosts.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-67322, ECHO-8b1b-6d4c-bcd1, GHSA-rwj8-pgh3-r573, MINI-6wwr-68q2-6xmp, MINI-gpjr-634j-7hcx, MINI-h5vp-9jg3-fcpj, MINI-hm57-jjp8-v73p, MINI-qxc3-4g97-q4wc, MINI-w4mg-v93p-3jwg, PYSEC-2026-3842, ROOT-APP-PYPI-CVE-2026-67322, ROOT-APP-PYPI-GHSA-rwj8-pgh3-r573, UBUNTU-CVE-2026-67322

## What is CVE-2026-67322?

CVE-2026-67322 is a high-severity vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitPython before 3.1.52 is vulnerable to environment-variable exfiltration in Repo.clone_from(). The caller-supplied remote URL is passed through Git.polish_url(), which on non-Cygwin platforms calls os.path.expandvars() on the URL before invoking git clone. An attacker who controls the clone URL can embed $NAME or ${NAME} tokens that are expanded to the values of the hosting process's environment variables (e.g., AWS_SECRET_ACCESS_KEY or GITHUB_TOKEN). The resulting URL, now containing the secret, is transmitted over the network to an attacker-controlled host during the clone attempt, disclosing the secret.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-67322?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.52 |
| `gitpython` | PyPI | All versions | 3.1.52 |
| `GitPython` | PyPI | All versions | 3.1.52 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-67322?

Upgrade gitpython to 3.1.52 or later.

## Is CVE-2026-67322 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67322 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67322 and fix it if it is affected.

What it is: CVE-2026-67322 is a high-severity vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67322 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.52
- gitpython (PyPI): affected all versions; fixed in 3.1.52
- GitPython (PyPI): affected all versions; fixed in 3.1.52

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67322/ (Markdown: https://insights.sbomify.com/CVE-2026-67322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67322
- OSV: https://osv.dev/vulnerability/CVE-2026-67322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67322/
Summaries are generated and may contain mistakes; the official description above is the record.
