# CVE-2026-67323: GitPython before 3.1.51 Command Injection via unguarded Git options

> Command injection in GitPython allows arbitrary command execution or file truncation if applications pass unvalidated arguments to specific repository methods.

- **Severity:** High 8.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-67323, ECHO-1512-9448-c75d, GHSA-956x-8gvw-wg5v, MINI-3hhj-qp9w-pg66, MINI-j2w5-9mxw-9c27, MINI-jc6m-mffq-7wmr, MINI-phc6-8vp2-6mxc, MINI-q8m3-5fpx-3r8v, PYSEC-2026-3839, ROOT-APP-PYPI-CVE-2026-67323, ROOT-APP-PYPI-GHSA-956x-8gvw-wg5v, UBUNTU-CVE-2026-67323

## What is CVE-2026-67323?

CVE-2026-67323 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

GitPython before 3.1.51 fails to guard against dangerous Git options passed as keyword arguments in Repo.archive() and git.ls_remote(), allowing command injection via options such as --exec/--upload-pack (leading to arbitrary command execution). Additionally, Repo.iter_commits() and Repo.blame() do not check for leading-dash revision arguments, so a revision like --output=<path> can cause Git to open and truncate an arbitrary file. Exploitation requires an application that passes attacker-controlled arguments to these methods.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-67323?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.51 |
| `gitpython` | PyPI | All versions | 3.1.51 |
| `GitPython` | PyPI | All versions | 3.1.51 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-67323?

Upgrade gitpython to 3.1.51 or later.

## Is CVE-2026-67323 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67323 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67323 and fix it if it is affected.

What it is: CVE-2026-67323 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67323 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.51
- gitpython (PyPI): affected all versions; fixed in 3.1.51
- GitPython (PyPI): affected all versions; fixed in 3.1.51

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67323/ (Markdown: https://insights.sbomify.com/CVE-2026-67323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67323
- OSV: https://osv.dev/vulnerability/CVE-2026-67323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67323/
Summaries are generated and may contain mistakes; the official description above is the record.
