# CVE-2026-67324: GitPython 3.1.50 Authentication Bypass via Joined Short Options

> Attackers can bypass unsafe option checks in GitPython to execute arbitrary commands via joined short options during repository cloning.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-67324, ECHO-362f-e6d7-712b, ECHO-df65-2075-ea5e, GHSA-v396-v7q4-x2qj, MINI-3h2x-g8cg-2rqm, MINI-5w74-m64m-qrh2, MINI-ghhj-m5pg-g47g, MINI-hw49-82mc-rcpc, PYSEC-2026-3947, ROOT-APP-PYPI-GHSA-v396-v7q4-x2qj, UBUNTU-CVE-2026-67324

## What is CVE-2026-67324?

CVE-2026-67324 is a critical command injection vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitPython 3.1.50 fails to recognize joined short-option forms such as -u<value> (the short form of --upload-pack=<value>) when enforcing its default unsafe-option gate. When an application passes attacker-influenced clone options into Repo.clone_from(..., multi_options=..., allow_unsafe_options=False), an attacker can supply -u<helper> to bypass the gate that blocks --upload-pack/-u, causing Git to execute the specified helper command during clone. Fixed in 3.1.51.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-67324?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | From 3.1.50 | 3.1.51 |
| `gitpython` | PyPI | From 3.1.50 | 3.1.51 |
| `GitPython` | PyPI | From 3.1.50 | 3.1.51 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-67324?

Upgrade gitpython to 3.1.51 or later.

## Is CVE-2026-67324 being exploited?

There is no known exploitation of CVE-2026-67324 in the wild and no public exploit code.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)
- [CVE-2026-87819](https://insights.sbomify.com/CVE-2026-87819/): GitPython before 3.1.60 Denial of Service via ReDoS (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67324 and fix it if it is affected.

What it is: CVE-2026-67324 is a critical command injection vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67324 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitpython (PyPI): affected from 3.1.50; fixed in 3.1.51
- gitpython (PyPI): affected from 3.1.50; fixed in 3.1.51
- GitPython (PyPI): affected from 3.1.50; fixed in 3.1.51

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67324/ (Markdown: https://insights.sbomify.com/CVE-2026-67324/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67324
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67324
- OSV: https://osv.dev/vulnerability/CVE-2026-67324

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67324/
Summaries are generated and may contain mistakes; the official description above is the record.
