# CVE-2026-67325: GitPython before 3.1.51 Command Injection via option prefix abbreviation

> Attackers can execute arbitrary commands by bypassing GitPython's option blocklist using git's long-option prefix abbreviation feature.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-67325, ECHO-4dec-46f6-0ebe, GHSA-2f96-g7mh-g2hx, MINI-74j5-7929-28wf, MINI-8ffr-3f79-gfjq, MINI-mqwh-gfrj-v89j, MINI-q6h7-xhrp-c59r, MINI-vf8q-m6gw-cxhm, PYSEC-2026-3836, ROOT-APP-PYPI-CVE-2026-67325, ROOT-APP-PYPI-GHSA-2f96-g7mh-g2hx, UBUNTU-CVE-2026-67325

## What is CVE-2026-67325?

CVE-2026-67325 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitPython before 3.1.51 contains an incomplete command injection blocklist that fails to account for git's long-option prefix abbreviation feature. Attackers can bypass the unsafe options guard by using abbreviated option names like upload_p instead of upload_pack, which git resolves to dangerous options and executes arbitrary commands.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-67325?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.51 |
| `gitpython` | PyPI | All versions | 3.1.51 |
| `GitPython` | PyPI | All versions | 3.1.51 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-67325?

Upgrade gitpython to 3.1.51 or later.

## Is CVE-2026-67325 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67325 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67325 and fix it if it is affected.

What it is: CVE-2026-67325 is a high-severity command injection vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67325 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.51
- gitpython (PyPI): affected all versions; fixed in 3.1.51
- GitPython (PyPI): affected all versions; fixed in 3.1.51

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67325/ (Markdown: https://insights.sbomify.com/CVE-2026-67325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67325
- OSV: https://osv.dev/vulnerability/CVE-2026-67325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67325/
Summaries are generated and may contain mistakes; the official description above is the record.
