# CVE-2026-67326: GitPython before 3.1.50 Newline Injection via config_writer section

> Attackers can inject newlines into GitPython config sections to forge hooksPath, enabling remote code execution when git hooks trigger.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-67326, ECHO-4413-137a-6247, ECHO-a193-9c05-86ff, GHSA-gmvg-8p66-77hg, GHSA-mv93-w799-cj2w, MINI-8gf4-6x7r-98x8, MINI-9c5c-c2c2-5jr4, MINI-r3v2-qxqq-9hh9, PYSEC-2026-3980, ROOT-APP-PYPI-GHSA-mv93-w799-cj2w, UBUNTU-CVE-2026-67326

## What is CVE-2026-67326?

CVE-2026-67326 is a high-severity code injection vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

GitPython before 3.1.50 fails to validate newline characters in the section parameter of config_writer(), allowing attackers to inject arbitrary section headers into .git/config. Attackers can inject newlines to create a forged [core] section with hooksPath pointing to attacker-controlled directories, achieving remote code execution when git hooks are triggered.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-67326?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.50 |
| `gitpython` | PyPI | All versions | 3.1.50 |
| `GitPython` | PyPI | All versions | 3.1.50 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-67326?

Upgrade gitpython to 3.1.50 or later.

## Is CVE-2026-67326 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67326 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67326 and fix it if it is affected.

What it is: CVE-2026-67326 is a high-severity code injection vulnerability in gitpython-developers GitPython, published on 1 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67326 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.50
- gitpython (PyPI): affected all versions; fixed in 3.1.50
- GitPython (PyPI): affected all versions; fixed in 3.1.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67326/ (Markdown: https://insights.sbomify.com/CVE-2026-67326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67326
- OSV: https://osv.dev/vulnerability/CVE-2026-67326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67326/
Summaries are generated and may contain mistakes; the official description above is the record.
