# CVE-2026-67327: better-auth before 1.6.22 Account Takeover via Magic-Link Email-OTP

> Attackers can hijack accounts by pre-registering with victim emails when open registration is enabled, retaining access after victim verification.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-9wm3-rh5c-fc37, GHSA-qq9h-g4jm-xgf3

## What is CVE-2026-67327?

CVE-2026-67327 is a high-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/password registration is enabled. An attacker registers an account with the victim's email address and an attacker-chosen password; the account remains unverified. When the legitimate owner later signs in via the magic-link or email-OTP passwordless flow, the account is marked verified without removing the pre-existing password or revoking existing sessions, so the attacker's password remains valid, granting persistent access to the victim's account. Fixed in 1.6.22 and 1.7.0-beta.10.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-67327?

4 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | From 1.1.3 | 1.6.22 |
| `better-auth` | npm | From 1.1.3 | 1.6.22 |
| `better-auth` | npm | From 1.7.0-beta.0 | 1.7.0-beta.10 |
| `better-auth` | npm | From 1.7.0-beta.0 | 1.7.0-beta.10 |

## How do I fix CVE-2026-67327?

Upgrade better-auth to a fixed version for your release line: 1.6.22 or 1.7.0-beta.10.

## Is CVE-2026-67327 being exploited?

There is no known exploitation of CVE-2026-67327 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67327 and fix it if it is affected.

What it is: CVE-2026-67327 is a high-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-67327 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected from 1.1.3; fixed in 1.6.22
- better-auth (npm): affected from 1.1.3; fixed in 1.6.22
- better-auth (npm): affected from 1.7.0-beta.0; fixed in 1.7.0-beta.10
- better-auth (npm): affected from 1.7.0-beta.0; fixed in 1.7.0-beta.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67327/ (Markdown: https://insights.sbomify.com/CVE-2026-67327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67327
- OSV: https://osv.dev/vulnerability/CVE-2026-67327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67327/
Summaries are generated and may contain mistakes; the official description above is the record.
