# CVE-2026-67329: @better-auth/stripe before 1.6.21 Authorization Bypass via Organization Subscription

> Authenticated users can bypass authorization checks to manage subscriptions and view billing details of other organizations they belong to but do not control.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-h3rm-78g3-j7cp, GHSA-mp8j-p2mc-4hgv

## What is CVE-2026-67329?

CVE-2026-67329 is a high-severity missing authorization vulnerability in better-auth stripe, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

@better-auth/stripe versions >= 1.4.11 and < 1.6.21, and >= 1.7.0-beta.0 and < 1.7.0-beta.10, contain an authorization bypass in organization subscription actions. The middleware validates the organization ID taken from the request query string against the authorizeReference callback, but the handler reads the organization ID only from the request body and falls back to the caller's active organization from their session. When these differ, an authenticated member of multiple organizations can perform subscription actions (cancel, change plan, restore, billing portal access) against an organization they belong to but should not manage, and can access another organization's billing details including payment methods, invoices, and subscription state.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-67329?

4 open source packages ship an affected version, including @better-auth/stripe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@better-auth/stripe` | npm | From 1.4.11 | 1.6.21 |
| `@better-auth/stripe` | npm | From 1.4.11 | 1.6.21 |
| `@better-auth/stripe` | npm | From 1.7.0-beta.0 | 1.7.0-beta.10 |
| `@better-auth/stripe` | npm | From 1.7.0-beta.0 | 1.7.0-beta.10 |

## How do I fix CVE-2026-67329?

Upgrade @better-auth/stripe to a fixed version for your release line: 1.6.21 or 1.7.0-beta.10.

## Is CVE-2026-67329 being exploited?

There is no known exploitation of CVE-2026-67329 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67329 and fix it if it is affected.

What it is: CVE-2026-67329 is a high-severity missing authorization vulnerability in better-auth stripe, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67329 in the wild and no public exploit code.

Affected packages and fixed versions:
- @better-auth/stripe (npm): affected from 1.4.11; fixed in 1.6.21
- @better-auth/stripe (npm): affected from 1.4.11; fixed in 1.6.21
- @better-auth/stripe (npm): affected from 1.7.0-beta.0; fixed in 1.7.0-beta.10
- @better-auth/stripe (npm): affected from 1.7.0-beta.0; fixed in 1.7.0-beta.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67329/ (Markdown: https://insights.sbomify.com/CVE-2026-67329/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67329
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67329
- OSV: https://osv.dev/vulnerability/CVE-2026-67329

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67329/
Summaries are generated and may contain mistakes; the official description above is the record.
