# CVE-2026-67330: better-auth SCIM 1.4.0-beta.27 through 1.6.21 Account Takeover via Provider-ID Collision

> Authenticated users can hijack accounts by minting SCIM tokens with colliding provider IDs, allowing unauthorized access and modification of global user data.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-6mwf-73fj-3358, GHSA-rjg6-39jm-rgg4

## What is CVE-2026-67330?

CVE-2026-67330 is a critical authentication bypass vulnerability in better-auth scim, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

@better-auth/scim (a better-auth plugin) versions >= 1.4.0-beta.27 through <= 1.6.21 and >= 1.7.0-beta.0 through <= 1.7.0-beta.9 contain an authorization bypass. SCIM token issuance did not reject provider IDs already used by existing SSO, SAML, OIDC, generic OAuth, or social account providers, and the same logical provider ID was used for both SCIM provider configuration and account ownership. An authenticated user could mint a SCIM token whose provider ID collided with an existing provider namespace, causing SCIM user routes to resolve account rows the token never provisioned. This allowed listing, reading, updating (including rewriting global profile/email fields without uniqueness checks), and deleting global user accounts and sessions, resulting in account takeover and unauthorized deprovisioning. Fixed in 1.6.22 and 1.7.0-beta.10 (1.7.0-rc.0).

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-67330?

4 open source packages ship an affected version, including @better-auth/scim.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@better-auth/scim` | npm | From 1.4.0-beta.27 | 1.6.22 |
| `@better-auth/scim` | npm | From 1.4.0-beta.27 | 1.6.22 |
| `@better-auth/scim` | npm | From 1.7.0-beta.0 | 1.7.0-beta.10 |
| `@better-auth/scim` | npm | From 1.7.0-beta.0 | 1.7.0-beta.10 |

## How do I fix CVE-2026-67330?

Upgrade @better-auth/scim to a fixed version for your release line: 1.6.22 or 1.7.0-beta.10.

## Is CVE-2026-67330 being exploited?

There is no known exploitation of CVE-2026-67330 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67330 and fix it if it is affected.

What it is: CVE-2026-67330 is a critical authentication bypass vulnerability in better-auth scim, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67330 in the wild and no public exploit code.

Affected packages and fixed versions:
- @better-auth/scim (npm): affected from 1.4.0-beta.27; fixed in 1.6.22
- @better-auth/scim (npm): affected from 1.4.0-beta.27; fixed in 1.6.22
- @better-auth/scim (npm): affected from 1.7.0-beta.0; fixed in 1.7.0-beta.10
- @better-auth/scim (npm): affected from 1.7.0-beta.0; fixed in 1.7.0-beta.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67330/ (Markdown: https://insights.sbomify.com/CVE-2026-67330/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67330
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67330
- OSV: https://osv.dev/vulnerability/CVE-2026-67330

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67330/
Summaries are generated and may contain mistakes; the official description above is the record.
