# CVE-2026-67331: better-auth SCIM 1.5.0 before 1.7.0-beta.4 Authorization Bypass

> Authenticated users can manage other users' SCIM providers and tokens due to missing ownership checks, enabling unauthorized access and privilege escalation.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-gj37-5j8h-j367, GHSA-j8v8-g9cx-5qf4

## What is CVE-2026-67331?

CVE-2026-67331 is a high-severity missing authorization vulnerability in better-auth scim, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

better-auth SCIM versions from 1.5.0 before 1.7.0-beta.4 fail to bind non-organization SCIM providers to their creator by default, allowing authenticated users to manage other users' providers. Attackers can regenerate SCIM bearer tokens, invalidate legitimate tokens, and authenticate to SCIM API routes with the attacker-controlled token.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-67331?

2 open source packages ship an affected version, including @better-auth/scim.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@better-auth/scim` | npm | From 1.5.0 | 1.7.0-beta.4 |
| `@better-auth/scim` | npm | From 1.5.0 | 1.7.0-beta.4 |

## How do I fix CVE-2026-67331?

Upgrade @better-auth/scim to 1.7.0-beta.4 or later.

## Is CVE-2026-67331 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67331 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67331 and fix it if it is affected.

What it is: CVE-2026-67331 is a high-severity missing authorization vulnerability in better-auth scim, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67331 exists.

Affected packages and fixed versions:
- @better-auth/scim (npm): affected from 1.5.0; fixed in 1.7.0-beta.4
- @better-auth/scim (npm): affected from 1.5.0; fixed in 1.7.0-beta.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67331/ (Markdown: https://insights.sbomify.com/CVE-2026-67331/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67331
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67331
- OSV: https://osv.dev/vulnerability/CVE-2026-67331

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67331/
Summaries are generated and may contain mistakes; the official description above is the record.
