# CVE-2026-67332: @better-auth/oauth-provider before 1.7.0-beta.4 Authorization Bypass

> Attackers can obtain access tokens for unauthorized resources by bypassing audience binding in the OAuth flow.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-hq9c-fvm2-pfh9, GHSA-p2fr-6hmx-4528

## What is CVE-2026-67332?

CVE-2026-67332 is a medium-severity authentication bypass vulnerability in better-auth oauth-provider, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

@better-auth/oauth-provider before 1.7.0-beta.4 fails to bind access-token audience to the authorization grant, allowing clients to request tokens for unrelated resources. Attackers can complete an OAuth flow and obtain access tokens whose audience targets resource servers the authorization never covered, bypassing intended authorization boundaries.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-67332?

2 open source packages ship an affected version, including @better-auth/oauth-provider.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@better-auth/oauth-provider` | npm | From 1.4.8 | 1.7.0-beta.4 |
| `@better-auth/oauth-provider` | npm | From 1.4.8 | 1.7.0-beta.4 |

## How do I fix CVE-2026-67332?

Upgrade @better-auth/oauth-provider to 1.7.0-beta.4 or later.

## Is CVE-2026-67332 being exploited?

There is no known exploitation of CVE-2026-67332 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67332 and fix it if it is affected.

What it is: CVE-2026-67332 is a medium-severity authentication bypass vulnerability in better-auth oauth-provider, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67332 in the wild and no public exploit code.

Affected packages and fixed versions:
- @better-auth/oauth-provider (npm): affected from 1.4.8; fixed in 1.7.0-beta.4
- @better-auth/oauth-provider (npm): affected from 1.4.8; fixed in 1.7.0-beta.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67332/ (Markdown: https://insights.sbomify.com/CVE-2026-67332/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67332
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67332
- OSV: https://osv.dev/vulnerability/CVE-2026-67332

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67332/
Summaries are generated and may contain mistakes; the official description above is the record.
