# CVE-2026-67334: better-auth Stale Sessions Persist After User Deletion

> Attackers can reuse session tokens of deleted users to maintain authentication for up to seven days when secondary storage is configured without database session storage.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-2vg6-77g8-24mp, GHSA-gj53-4jmf-7745

## What is CVE-2026-67334?

CVE-2026-67334 is a medium-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

better-auth versions before 1.6.11 fail to delete cached sessions when removing users via admin, anonymous, or SCIM endpoints when secondaryStorage is configured and storeSessionInDatabase is false. Attackers can reuse deleted user session tokens to maintain authentication for up to seven days after account deletion.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2026-67334?

4 open source packages ship an affected version, including @better-auth/scim and better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@better-auth/scim` | npm | From 1.6.0 | 1.6.11 |
| `@better-auth/scim` | npm | From 1.6.0 | 1.6.11 |
| `better-auth` | npm | From 0.3.4 | 1.6.11 |
| `better-auth` | npm | From 0.3.4 | 1.6.11 |

## How do I fix CVE-2026-67334?

Upgrade @better-auth/scim to 1.6.11 or later.

## Is CVE-2026-67334 being exploited?

There is no known exploitation of CVE-2026-67334 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67334 and fix it if it is affected.

What it is: CVE-2026-67334 is a medium-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67334 in the wild and no public exploit code.

Affected packages and fixed versions:
- @better-auth/scim (npm): affected from 1.6.0; fixed in 1.6.11
- @better-auth/scim (npm): affected from 1.6.0; fixed in 1.6.11
- better-auth (npm): affected from 0.3.4; fixed in 1.6.11
- better-auth (npm): affected from 0.3.4; fixed in 1.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67334/ (Markdown: https://insights.sbomify.com/CVE-2026-67334/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67334
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67334
- OSV: https://osv.dev/vulnerability/CVE-2026-67334

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67334/
Summaries are generated and may contain mistakes; the official description above is the record.
