# CVE-2026-67335: better-auth before 1.6.2 OAuth State Validation Bypass

> Attackers can bypass OAuth state validation to hijack sessions or link accounts when using cookie-backed state without PKCE.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-4hp3-gxv8-7g37, GHSA-wxw3-q3m9-c3jr

## What is CVE-2026-67335?

CVE-2026-67335 is a medium-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

better-auth versions before 1.6.2 fail to validate the OAuth state parameter against the stored nonce when using cookie-backed state storage without PKCE. Attackers can forge the state parameter and supply an attacker-controlled authorization code to create authenticated sessions bound to the attacker's external identity or persistently link attacker accounts to victim profiles.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-67335?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.6.2 |
| `better-auth` | npm | All versions | 1.6.2 |

## How do I fix CVE-2026-67335?

Upgrade better-auth to 1.6.2 or later.

## Is CVE-2026-67335 being exploited?

There is no known exploitation of CVE-2026-67335 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67335 and fix it if it is affected.

What it is: CVE-2026-67335 is a medium-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-67335 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.6.2
- better-auth (npm): affected all versions; fixed in 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67335/ (Markdown: https://insights.sbomify.com/CVE-2026-67335/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67335
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67335
- OSV: https://osv.dev/vulnerability/CVE-2026-67335

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67335/
Summaries are generated and may contain mistakes; the official description above is the record.
