# CVE-2026-67336: better-auth before 1.6.11 Insecure Cryptographic Defaults via oidcProvider

> Attackers can bypass authentication or intercept codes due to insecure cryptographic defaults in the oidcProvider plugin.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-9h47-pqcx-hjr4, GHSA-mw34-3w2r-wp9p

## What is CVE-2026-67336?

CVE-2026-67336 is a critical vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

better-auth versions before 1.6.11 contain insecure cryptographic defaults in the oidcProvider and mcp plugins that advertise the none algorithm and accept plain PKCE by default. Attackers can exploit algorithm negotiation to accept unsigned tokens or intercept authorization codes when PKCE plain is used instead of the required S256 method.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2026-67336?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.6.11 |
| `better-auth` | npm | All versions | 1.6.11 |

## How do I fix CVE-2026-67336?

Upgrade better-auth to 1.6.11 or later.

## Is CVE-2026-67336 being exploited?

There is no known exploitation of CVE-2026-67336 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67336 and fix it if it is affected.

What it is: CVE-2026-67336 is a critical vulnerability in better-auth, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67336 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.6.11
- better-auth (npm): affected all versions; fixed in 1.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67336/ (Markdown: https://insights.sbomify.com/CVE-2026-67336/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67336
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67336
- OSV: https://osv.dev/vulnerability/CVE-2026-67336

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67336/
Summaries are generated and may contain mistakes; the official description above is the record.
