# CVE-2026-67337: better-auth before 1.4.9 Two-Factor Authentication Bypass via session.cookieCache

> Attackers with valid credentials can bypass two-factor authentication in better-auth when session caching is enabled, accessing protected routes without second-factor verification.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-8pwm-pjg9-4h92, GHSA-xg6x-h9c9-2m83

## What is CVE-2026-67337?

CVE-2026-67337 is a high-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

better-auth versions before 1.4.9 contain a two-factor authentication bypass vulnerability when session.cookieCache is enabled. Attackers with valid primary credentials can access authenticated routes without completing second-factor verification by exploiting premature session caching.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-67337?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.4.9 |
| `better-auth` | npm | All versions | 1.4.9 |

## How do I fix CVE-2026-67337?

Upgrade better-auth to 1.4.9 or later.

## Is CVE-2026-67337 being exploited?

There is no known exploitation of CVE-2026-67337 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67337 and fix it if it is affected.

What it is: CVE-2026-67337 is a high-severity authentication bypass vulnerability in better-auth, published on 1 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67337 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.4.9
- better-auth (npm): affected all versions; fixed in 1.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67337/ (Markdown: https://insights.sbomify.com/CVE-2026-67337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67337
- OSV: https://osv.dev/vulnerability/CVE-2026-67337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67337/
Summaries are generated and may contain mistakes; the official description above is the record.
