{"answers":{"affected":"3 open source packages ship an affected version, including jupyterlab.","exploited":"There is no known exploitation of CVE-2026-67338 in the wild and no public exploit code.","fix":"Upgrade jupyterlab to 4.5.9 or later.","what":"CVE-2026-67338 is a medium-severity cross-site scripting vulnerability in jupyterlab, published on 1 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-67338 and fix it if it is affected.\n\nWhat it is: CVE-2026-67338 is a medium-severity cross-site scripting vulnerability in jupyterlab, published on 1 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-67338 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyterlab (Bitnami): affected all versions; fixed in 4.5.9\n- jupyterlab (PyPI): affected all versions; fixed in 4.5.9\n- jupyterlab (PyPI): affected all versions; fixed in 4.5.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-67338/ (Markdown: https://insights.sbomify.com/CVE-2026-67338/index.md)","id":"CVE-2026-67338","markdown":"https://insights.sbomify.com/CVE-2026-67338/index.md","name":"CVE-2026-67338","record":{"aliases":["BIT-jupyterlab-2026-67338","CLEANSTART-2026-HX81668","DEBIAN-CVE-2026-67338","GHSA-r75g-r7w6-363h","GHSA-vmhf-c436-hxj4","UBUNTU-CVE-2026-67338"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"JupyterLab","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript in JupyterLab via malicious PyPI packages with javascript: URLs in metadata, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-84","name":"Improper Neutralization of Encoded URI Schemes in a Web Page"}],"description":"JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JupyterLab before 4.5.9 Stored XSS via Extension Manager","id":"CVE-2026-67338","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"guzzlehttp/guzzle before 7.14.2 Proxy-Authorization Header Disclosure","id":"CVE-2026-67339"},"packages":[{"ecosystem":"Bitnami","fixed":["4.5.9"],"introduced":["0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:bitnami/jupyterlab","source":"BIT-jupyterlab-2026-67338"},{"ecosystem":"PyPI","fixed":["4.5.9"],"introduced":["0"],"last_affected":[],"package":"jupyterlab","purl":null,"source":"GHSA-vmhf-c436-hxj4"},{"ecosystem":"PyPI","fixed":["4.5.9"],"introduced":["0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"GHSA-vmhf-c436-hxj4"}],"prev":{"headline":"better-auth before 1.4.9 Two-Factor Authentication Bypass via session.cookieCache","id":"CVE-2026-67337"},"products":["jupyterlab"],"published":"2026-08-01","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["jupyterlab"]},"summary":"Attackers can execute arbitrary JavaScript in JupyterLab via malicious PyPI packages with javascript: URLs in metadata, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-67338/"}