# CVE-2026-67338: JupyterLab before 4.5.9 Stored XSS via Extension Manager

> Attackers can execute arbitrary JavaScript in JupyterLab via malicious PyPI packages with javascript: URLs in metadata, potentially leading to account takeover.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-jupyterlab-2026-67338, CLEANSTART-2026-HX81668, DEBIAN-CVE-2026-67338, GHSA-r75g-r7w6-363h, GHSA-vmhf-c436-hxj4, UBUNTU-CVE-2026-67338

## What is CVE-2026-67338?

CVE-2026-67338 is a medium-severity cross-site scripting vulnerability in jupyterlab, published on 1 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.

Weakness: CWE-84 (Improper Neutralization of Encoded URI Schemes in a Web Page)

## Which versions are affected by CVE-2026-67338?

3 open source packages ship an affected version, including jupyterlab.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterlab` | Bitnami | All versions | 4.5.9 |
| `jupyterlab` | PyPI | All versions | 4.5.9 |
| `jupyterlab` | PyPI | All versions | 4.5.9 |

## How do I fix CVE-2026-67338?

Upgrade jupyterlab to 4.5.9 or later.

## Is CVE-2026-67338 being exploited?

There is no known exploitation of CVE-2026-67338 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67338 and fix it if it is affected.

What it is: CVE-2026-67338 is a medium-severity cross-site scripting vulnerability in jupyterlab, published on 1 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-67338 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterlab (Bitnami): affected all versions; fixed in 4.5.9
- jupyterlab (PyPI): affected all versions; fixed in 4.5.9
- jupyterlab (PyPI): affected all versions; fixed in 4.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67338/ (Markdown: https://insights.sbomify.com/CVE-2026-67338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67338
- OSV: https://osv.dev/vulnerability/CVE-2026-67338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67338/
Summaries are generated and may contain mistakes; the official description above is the record.
