CVE-2026-6734 undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse
Attackers can route requests to unintended origins via SOCKS5 proxy pool reuse, leaking credentials and downgrading HTTPS to HTTP in Node.js applications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6734?
CVE-2026-6734 is a high-severity server-side request forgery vulnerability in Nodejs Undici, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Impact: When using Socks5ProxyAgent, undici reuses a single connection pool across different origins without verifying that the pool's origin matches the requested origin. All requests are dispatched through the pool connected to the first origin, regardless of the intended destination.
This causes cross-origin request routing: credentials and request data intended for origin B are sent to origin A, responses from the wrong origin are trusted, and HTTPS requests may be silently downgraded to HTTP.
Impacted users are applications that use Socks5ProxyAgent (directly or via setGlobalDispatcher) and make requests to more than one origin.
This was introduced in undici 7.23.0 via PR #4385 and affects all versions through 8.1.0.
Patches: Upgrade to undici v7.26.0 or v8.2.0.
Workarounds: Use a separate Socks5ProxyAgent instance per origin, or avoid using Socks5ProxyAgent with multiple origins.
Which versions are affected by CVE-2026-6734?
4 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.23.0 | 7.28.0 |
undici npm | From 7.23.0 | 7.28.0 |
undici npm | From 8.0.0 | 8.2.0 |
undici npm | From 8.0.0 | 8.2.0 |
Products include Nodejs Undici.
How do I fix CVE-2026-6734?
Upgrade undici to a fixed version for your release line: 7.28.0 or 8.2.0.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-6734 being exploited?
There is no known exploitation of CVE-2026-6734 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as DEBIAN-CVE-2026-6734, ECHO-ca6a-bea6-ea52, GHSA-hm92-r4w5-c3mj, MINI-22hj-q7cq-q7m9, MINI-45q2-8r6g-wc7f, MINI-8542-w4hq-8944 and 5 more.