# CVE-2026-6734: undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse

> Attackers can route requests to unintended origins via SOCKS5 proxy pool reuse, leaking credentials and downgrading HTTPS to HTTP in Node.js applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 10 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-6734, ECHO-ca6a-bea6-ea52, GHSA-hm92-r4w5-c3mj, MINI-22hj-q7cq-q7m9, MINI-45q2-8r6g-wc7f, MINI-8542-w4hq-8944, MINI-93hg-57wx-ww2x, MINI-q677-h6rw-2j57, MINI-vqrf-gr9p-r4jr, ROOT-APP-NPM-CVE-2026-6734, UBUNTU-CVE-2026-6734

## What is CVE-2026-6734?

CVE-2026-6734 is a high-severity server-side request forgery vulnerability in Nodejs Undici, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Impact:
When using Socks5ProxyAgent, undici reuses a single connection pool across different origins without verifying that the pool's origin matches the requested origin. All requests are dispatched through the pool connected to the first origin, regardless of the intended destination.

This causes cross-origin request routing: credentials and request data intended for origin B are sent to origin A, responses from the wrong origin are trusted, and HTTPS requests may be silently downgraded to HTTP.

Impacted users are applications that use Socks5ProxyAgent (directly or via setGlobalDispatcher) and make requests to more than one origin.

This was introduced in undici 7.23.0 via PR #4385 and affects all versions through 8.1.0.

Patches:
Upgrade to undici v7.26.0 or v8.2.0.

Workarounds:
Use a separate Socks5ProxyAgent instance per origin, or avoid using Socks5ProxyAgent with multiple origins.

Weakness: CWE-940 (Improper Verification of Source of a Communication Channel), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-6734?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.23.0 | 7.28.0 |
| `undici` | npm | From 7.23.0 | 7.28.0 |
| `undici` | npm | From 8.0.0 | 8.2.0 |
| `undici` | npm | From 8.0.0 | 8.2.0 |

Products: Nodejs Undici.

## How do I fix CVE-2026-6734?

Upgrade undici to a fixed version for your release line: 7.28.0 or 8.2.0.

## Is CVE-2026-6734 being exploited?

There is no known exploitation of CVE-2026-6734 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6734 and fix it if it is affected.

What it is: CVE-2026-6734 is a high-severity server-side request forgery vulnerability in Nodejs Undici, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6734 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.23.0; fixed in 7.28.0
- undici (npm): affected from 7.23.0; fixed in 7.28.0
- undici (npm): affected from 8.0.0; fixed in 8.2.0
- undici (npm): affected from 8.0.0; fixed in 8.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6734/ (Markdown: https://insights.sbomify.com/CVE-2026-6734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6734
- OSV: https://osv.dev/vulnerability/CVE-2026-6734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6734/
Summaries are generated and may contain mistakes; the official description above is the record.
