# CVE-2026-67340: ArcadeDB before 26.7.2 Remote Code Execution via Trigger Scripts

> Authenticated users with schema update permissions can execute arbitrary OS commands via malicious JavaScript triggers in ArcadeDB.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** GHSA-w8vx-3rmm-v7rp, GHSA-x9f9-r4m8-9xc2

## What is CVE-2026-67340?

CVE-2026-67340 is a high-severity code injection vulnerability in ArcadeData arcadedb, published on 1 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

ArcadeDB before 26.7.2 (arcadedb-engine) allows trigger scripts to look up host classes in java.lang.* (via Java.type) because ScriptTriggerExecutor adds java.lang.* to the allowed packages. An authenticated user with UPDATE_SCHEMA permission can create a JavaScript trigger that invokes java.lang.Runtime.getRuntime().exec() (or ProcessBuilder), achieving OS command execution when the trigger fires.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-67340?

2 open source packages ship an affected version, including com.arcadedb:arcadedb-engine.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.arcadedb:arcadedb-engine` | Maven | All versions | 26.7.2 |
| `com.arcadedb:arcadedb-engine` | Maven | All versions | 26.7.2 |

## How do I fix CVE-2026-67340?

Upgrade com.arcadedb:arcadedb-engine to 26.7.2 or later.

## Is CVE-2026-67340 being exploited?

There is no known exploitation of CVE-2026-67340 in the wild and no public exploit code.

Public exploit code:

- https://github.com/0xdak/CVE-2026-67340_exploit (github_poc): https://github.com/0xdak/CVE-2026-67340_exploit

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67340 and fix it if it is affected.

What it is: CVE-2026-67340 is a high-severity code injection vulnerability in ArcadeData arcadedb, published on 1 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67340 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.arcadedb:arcadedb-engine (Maven): affected all versions; fixed in 26.7.2
- com.arcadedb:arcadedb-engine (Maven): affected all versions; fixed in 26.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67340/ (Markdown: https://insights.sbomify.com/CVE-2026-67340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67340
- OSV: https://osv.dev/vulnerability/CVE-2026-67340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67340/
Summaries are generated and may contain mistakes; the official description above is the record.
