CVE-2026-6735 XSS within PHP-FPM status endpoint
An attacker can execute arbitrary JavaScript on a victim's machine by crafting a URL that exploits improper sanitation in the PHP-FPM status endpoint.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-6735?
CVE-2026-6735 is a high-severity cross-site scripting vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, 8.5.* before 8.5.6, due to improper sanitation of user data, it allows an attacker to compose an URL, which will cause the target to execute arbitrary JavaScript code (XSS) on the target's machine when the target is viewing the PHP-FPM status page.
Weakness: CWE-79
Which versions are affected by CVE-2026-6735?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
php Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
php-min Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
Products include Php Php.
How do I fix CVE-2026-6735?
Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-6735 being exploited?
There is no known exploitation of CVE-2026-6735 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as AZL-86352, BELL-CVE-2026-6735, BIT-libphp-2026-6735, BIT-php-2026-6735, BIT-php-min-2026-6735, CLSA-2026-1778603120 and 15 more.