{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-6735 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.","what":"CVE-2026-6735 is a high-severity cross-site scripting vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-6735 and fix it if it is affected.\n\nWhat it is: CVE-2026-6735 is a high-severity cross-site scripting vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-6735 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6\n- php (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6\n- php-min (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6735/ (Markdown: https://insights.sbomify.com/CVE-2026-6735/index.md)","id":"CVE-2026-6735","markdown":"https://insights.sbomify.com/CVE-2026-6735/index.md","name":"CVE-2026-6735","record":{"aliases":["AZL-86352","BELL-CVE-2026-6735","BIT-libphp-2026-6735","BIT-php-2026-6735","BIT-php-min-2026-6735","CLSA-2026-1778603120","CLSA-2026-1778670534","CLSA-2026-1778670864","CLSA-2026-1778687453","CLSA-2026-1778751841","CLSA-2026-1779123668","CLSA-2026-1779292803","CLSA-2026-1779787232","CLSA-2026-1780513989","DEBIAN-CVE-2026-6735","ECHO-77fa-c683-7b30","MINI-2wc4-p57m-22rq","MINI-9j94-x3w2-hwh4","MINI-f8w4-qxgr-vqf6","MINI-g3g9-g4p9-rg82","UBUNTU-CVE-2026-6735"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP-FPM status page","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript on a victim's machine by crafting a URL that exploits improper sanitation in the PHP-FPM status endpoint.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N/E:P/S:P/AU:Y/RE:L/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, 8.5.* before 8.5.6, due to improper sanitation of user data, it allows an attacker to compose an URL, which will cause the target to execute arbitrary JavaScript code (XSS) on the target's machine when the target is viewing the PHP-FPM status page.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS within PHP-FPM status endpoint","id":"CVE-2026-6735","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"xss","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Auth bypass in Enterprise Server","id":"CVE-2026-6736"},"packages":[{"ecosystem":"Bitnami","fixed":["8.2.31","8.3.31","8.4.21","8.5.6"],"introduced":["8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2026-6735"},{"ecosystem":"Bitnami","fixed":["8.2.31","8.3.31","8.4.21","8.5.6"],"introduced":["8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2026-6735"},{"ecosystem":"Bitnami","fixed":["8.2.31","8.3.31","8.4.21","8.5.6"],"introduced":["8.2.0","8.3.0","8.4.0","8.5.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2026-6735"}],"prev":{"headline":"undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse","id":"CVE-2026-6734"},"products":["PHP"],"published":"2026-05-10","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["PHP Group"]},"summary":"An attacker can execute arbitrary JavaScript on a victim's machine by crafting a URL that exploits improper sanitation in the PHP-FPM status endpoint.","url":"https://insights.sbomify.com/CVE-2026-6735/"}