# CVE-2026-6735: XSS within PHP-FPM status endpoint

> An attacker can execute arbitrary JavaScript on a victim's machine by crafting a URL that exploits improper sanitation in the PHP-FPM status endpoint.

- **Severity:** High 7.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N/E:P/S:P/AU:Y/RE:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 May 2026
- **Updated:** 11 May 2026
- **Also known as:** AZL-86352, BELL-CVE-2026-6735, BIT-libphp-2026-6735, BIT-php-2026-6735, BIT-php-min-2026-6735, CLSA-2026-1778603120, CLSA-2026-1778670534, CLSA-2026-1778670864, CLSA-2026-1778687453, CLSA-2026-1778751841, CLSA-2026-1779123668, CLSA-2026-1779292803, CLSA-2026-1779787232, CLSA-2026-1780513989, DEBIAN-CVE-2026-6735, ECHO-77fa-c683-7b30, MINI-2wc4-p57m-22rq, MINI-9j94-x3w2-hwh4, MINI-f8w4-qxgr-vqf6, MINI-g3g9-g4p9-rg82, UBUNTU-CVE-2026-6735

## What is CVE-2026-6735?

CVE-2026-6735 is a high-severity cross-site scripting vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, 8.5.* before 8.5.6, due to improper sanitation of user data, it allows an attacker to compose an URL, which will cause the target to execute arbitrary JavaScript code (XSS) on the target's machine when the target is viewing the PHP-FPM status page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-6735?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
| `php` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |
| `php-min` | Bitnami | From 8.2.0 | 8.2.31, 8.3.31, 8.4.21, 8.5.6 |

Products: Php Php.

## How do I fix CVE-2026-6735?

Upgrade libphp to a fixed version for your release line: 8.2.31, 8.3.31, 8.4.21 or 8.5.6.

## Is CVE-2026-6735 being exploited?

There is no known exploitation of CVE-2026-6735 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6735 and fix it if it is affected.

What it is: CVE-2026-6735 is a high-severity cross-site scripting vulnerability in Php Php, published on 10 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-6735 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6
- php (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6
- php-min (Bitnami): affected from 8.2.0; fixed in 8.2.31, 8.3.31, 8.4.21, 8.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6735/ (Markdown: https://insights.sbomify.com/CVE-2026-6735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6735
- OSV: https://osv.dev/vulnerability/CVE-2026-6735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6735/
Summaries are generated and may contain mistakes; the official description above is the record.
