# CVE-2026-67355: guzzlehttp/guzzle before 7.15.1 Host-only Cookie Scope

> Attackers controlling child hosts can steal host-only cookies, including session identifiers and tokens, from the parent host's cookie jar.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-67355, GHSA-wm3w-8rrp-j577, MINI-39cp-76w6-73qx, MINI-f559-rh4q-xhp9, MINI-jxr3-w9w3-6729, MINI-m5gr-jwpq-f3h3, MINI-p4x9-qc62-x49q, MINI-qr48-r2q3-cvm5, MINI-x3c2-hmjw-vccm, MINI-xxx5-9452-6gqh, UBUNTU-CVE-2026-67355

## What is CVE-2026-67355?

CVE-2026-67355 is a high-severity vulnerability in guzzle, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

guzzlehttp/guzzle versions before 7.15.1 fail to preserve host-only cookie scope, storing the request host in the Domain field instead of marking cookies as host-only. Attackers controlling child hosts can receive host-only cookies intended only for parent hosts, potentially disclosing session identifiers and authorization tokens when the same cookie jar is reused across trust boundaries.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-67355?

2 open source packages ship an affected version, including guzzlehttp/guzzle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guzzlehttp/guzzle` | Packagist | All versions | 7.15.1 |
| `guzzlehttp/guzzle` | Packagist | All versions | 7.15.1 |

## How do I fix CVE-2026-67355?

Upgrade guzzlehttp/guzzle to 7.15.1 or later.

## Is CVE-2026-67355 being exploited?

There is no known exploitation of CVE-2026-67355 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67355 and fix it if it is affected.

What it is: CVE-2026-67355 is a high-severity vulnerability in guzzle, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67355 in the wild and no public exploit code.

Affected packages and fixed versions:
- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 7.15.1
- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 7.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67355/ (Markdown: https://insights.sbomify.com/CVE-2026-67355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67355
- OSV: https://osv.dev/vulnerability/CVE-2026-67355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67355/
Summaries are generated and may contain mistakes; the official description above is the record.
