# CVE-2026-67405: RabbitMQ: CSWSH on Web-STOMP / Web-MQTT (no Origin validation)

> Attackers can hijack user sessions via Cross-Site WebSocket Hijacking in RabbitMQ Web-STOMP/MQTT plugins when specific authentication settings are enabled.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** AZL-105747, BIT-rabbitmq-2026-67405, DEBIAN-CVE-2026-67405, GHSA-9c4f-rxxm-88q3, UBUNTU-CVE-2026-67405

## What is CVE-2026-67405?

CVE-2026-67405 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, Neither the Web-MQTT handler (deps/rabbitmq_web_mqtt/src/rabbit_web_mqtt_handler.erl:104) nor the Web-STOMP handler (deps/rabbitmq_web_stomp/src/rabbit_web_stomp_handler.erl:102) validates the Origin header on the WebSocket upgrade. Under ssl_cert_login=true, the browser presents the client certificate automatically, so an attacker's JavaScript running in the victim's browser can authenticate as the victim. Preconditions include The non-default configuration use_http_auth=true (Web-STOMP) or ssl_cert_login=true (both plugins) must be enabled. The issue is harmless under the default in-band CONNECT credential configuration.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2026-67405?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 3.13.0 | 3.13.15, 4.0.20, 4.1.11, 4.2.6 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-67405?

Upgrade rabbitmq to a fixed version for your release line: 3.13.15, 4.0.20, 4.1.11 or 4.2.6.

## Is CVE-2026-67405 being exploited?

There is no known exploitation of CVE-2026-67405 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67405 and fix it if it is affected.

What it is: CVE-2026-67405 is a medium-severity vulnerability in Broadcom Rabbitmq Server, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-67405 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 3.13.0; fixed in 3.13.15, 4.0.20, 4.1.11, 4.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67405/ (Markdown: https://insights.sbomify.com/CVE-2026-67405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67405
- OSV: https://osv.dev/vulnerability/CVE-2026-67405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67405/
Summaries are generated and may contain mistakes; the official description above is the record.
