{"answers":{"affected":"1 open source package ship an affected version, including rabbitmq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67413 exists.","fix":"Upgrade rabbitmq to a fixed version for your release line: 4.0.23, 4.1.14, 4.2.9 or 4.3.3.","what":"CVE-2026-67413 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-67413 and fix it if it is affected.\n\nWhat it is: CVE-2026-67413 is a medium-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67413 exists.\n\nAffected packages and fixed versions:\n- rabbitmq (Bitnami): affected from 4.0.0; fixed in 4.0.23, 4.1.14, 4.2.9, 4.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-67413/ (Markdown: https://insights.sbomify.com/CVE-2026-67413/index.md)","id":"CVE-2026-67413","markdown":"https://insights.sbomify.com/CVE-2026-67413/index.md","name":"CVE-2026-67413","record":{"aliases":["AZL-105314","BIT-rabbitmq-2026-67413","DEBIAN-CVE-2026-67413","GHSA-chxf-3hfg-j8f7","UBUNTU-CVE-2026-67413"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"RabbitMQ message broker","requires_auth":"low_privilege","summary":"Authenticated users can cause denial of service in RabbitMQ by submitting pathological JMS topic selectors that exhaust broker CPU resources.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rabbitmq_server","vendor":"broadcom"}],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.23, 4.1.14, 4.2.9, and 4.3.3, the optional rabbitmq_jms_topic_exchange plugin's x-jms-topic exchange accepted a client-controlled rjms_erlang_selector binding expression whose LIKE evaluator expanded percent and underscore wildcards into overlapping PCRE fragments. It executed those fragments with raw re:run/3 without match or recursion limits, allowing an authenticated tenant that can bind and publish to consume broker scheduler CPU and deny service with pathological selectors. This issue is fixed in versions 4.0.23, 4.1.14, 4.2.9, and 4.3.3.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in rabbitmq-server","id":"CVE-2026-67413","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"broadcom:rabbitmq_server","products":["broadcom:rabbitmq_server"],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":7,"next":{"headline":"RabbitMQ AMQP 1.0 parser: amplification memory-exhaustion DoS via zero-width array aggregation","id":"CVE-2026-67414"},"packages":[{"ecosystem":"Bitnami","fixed":["4.0.23","4.1.14","4.2.9","4.3.3"],"introduced":["4.0.0","4.1.0","4.2.0","4.3.0"],"last_affected":[],"package":"rabbitmq","purl":"pkg:bitnami/rabbitmq","source":"BIT-rabbitmq-2026-67413"}],"prev":{"headline":"RabbitMQ: Federation upstream skips vhost authorization allowing cross-vhost message access","id":"CVE-2026-67412"},"products":["rabbitmq-server"],"published":"2026-09-25","related":[{"cvss_score":9.8,"headline":"Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7","id":"CVE-2016-9877","kev_date_added":null,"published":"2016-12-29"},{"cvss_score":9.2,"headline":"RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch","id":"CVE-2026-67404","kev_date_added":null,"published":"2026-09-23"},{"cvss_score":9.1,"headline":"RabbitMQ: Trust-store whitelist by Issuer+Serial only","id":"CVE-2026-67231","kev_date_added":null,"published":"2026-09-23"},{"cvss_score":8.7,"headline":"Information disclosure in rabbitmq-server","id":"CVE-2026-57219","kev_date_added":null,"published":"2026-07-10"},{"cvss_score":8.2,"headline":"RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login","id":"CVE-2026-67236","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":8.2,"headline":"RabbitMQ: JWKS Fetch Ignores HTTP Response Status Code - Signing Key Destruction Causes Authentication DoS","id":"CVE-2026-67409","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":8.2,"headline":"RabbitMQ: OAuth2 Client Secret Exposed via Unauthenticated JavaScript Endpoint","id":"CVE-2026-67410","kev_date_added":null,"published":"2026-09-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["rabbitmq"]},"summary":"Authenticated users can cause denial of service in RabbitMQ by submitting pathological JMS topic selectors that exhaust broker CPU resources.","url":"https://insights.sbomify.com/CVE-2026-67413/"}