# CVE-2026-67421: RabbitMQ: Stored HTML Injection in RabbitMQ Management OAuth Error Handling

> An attacker with queue configure permission can inject HTML into the RabbitMQ Management UI to steal administrator credentials via OAuth token leakage.

- **Severity:** Medium 4.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** AZL-105323, BIT-rabbitmq-2026-67421, DEBIAN-CVE-2026-67421, GHSA-6256-27fm-4rgr, UBUNTU-CVE-2026-67421

## What is CVE-2026-67421?

CVE-2026-67421 is a medium-severity cross-site scripting vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5, RabbitMQ Management rendered an AMQP authorization-error reason containing an attacker-controlled queue name as HTML when the OAuth management UI was enabled. Exploitation requires an attacker with queue configure permission, a management administrator who can see but cannot read that queue, and the administrator clicking Get Message(s). A queue name containing a base element can then retarget the automatic relative refresh because the Content Security Policy omits base-uri and connect-src, and an attacker endpoint that permits the management origin through CORS can receive the victim's Authorization header. This issue is fixed in versions 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-67421?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 3.13.0 | 3.13.19, 4.0.24, 4.1.15, 4.2.10, 4.3.5 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-67421?

Upgrade rabbitmq to a fixed version for your release line: 3.13.19, 4.0.24, 4.1.15 or 4.2.10.

## Is CVE-2026-67421 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67421 exists.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67421 and fix it if it is affected.

What it is: CVE-2026-67421 is a medium-severity cross-site scripting vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67421 exists.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 3.13.0; fixed in 3.13.19, 4.0.24, 4.1.15, 4.2.10, 4.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67421/ (Markdown: https://insights.sbomify.com/CVE-2026-67421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67421
- OSV: https://osv.dev/vulnerability/CVE-2026-67421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67421/
Summaries are generated and may contain mistakes; the official description above is the record.
