CVE-2026-67422 pymdown-extensions: Exponential-backtracking ReDoS in caret, tilde, betterem, and magiclink inline processors

High 7.5 Published Updated

An attacker can cause denial of service via exponential backtracking in regular expressions when rendering untrusted Markdown input.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-67422?

CVE-2026-67422 is a high-severity denial of service vulnerability in facelessuser pymdown-extensions, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

pymdown-extensions is a collection of extensions for the Python Markdown library. In versions up to and including 11.0, four inline processors (caret, tilde, betterem, and magiclink) use regular expressions whose content groups can partition a run of delimiter characters in exponentially many ways, causing catastrophic backtracking. As a result, a single untrusted Markdown line under 50 bytes rendered with markdown.markdown() in each extension's default configuration drives the rendering thread into unbounded CPU usage that grows exponentially with input length, enabling an unauthenticated remote attacker who can submit Markdown to cause denial of service. The exposure is concrete for web applications that render user-supplied Markdown (comments, wikis, issue bodies, live preview), including any app using pymdownx.extra which bundles the vulnerable betterem default, as well as hosted docs/CI systems that build untrusted Markdown. The issue has been fixed in version 11.0.1.

Weakness: CWE-1333

Which versions are affected by CVE-2026-67422?

3 open source packages ship an affected version, including pymdown-extensions.

PackageAffectedFixed in
pymdown-extensions PyPIAll versions11.0.1
pymdown-extensions PyPIAll versions11.0.1
pymdown-extensions PyPIAll versions11.0.1

How do I fix CVE-2026-67422?

Upgrade pymdown-extensions to 11.0.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-67422 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67422 exists.

Sources

Also known as DEBIAN-CVE-2026-67422, ECHO-bc8f-97a6-da0b, GHSA-gm37-52c6-37mw, PYSEC-2026-3654, ROOT-APP-PYPI-CVE-2026-67422, UBUNTU-CVE-2026-67422.

Is CVE-2026-67422 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free