# CVE-2026-67422: pymdown-extensions: Exponential-backtracking ReDoS in caret, tilde, betterem, and magiclink inline processors

> An attacker can cause denial of service via exponential backtracking in regular expressions when rendering untrusted Markdown input.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-67422, ECHO-bc8f-97a6-da0b, GHSA-gm37-52c6-37mw, PYSEC-2026-3654, ROOT-APP-PYPI-CVE-2026-67422, UBUNTU-CVE-2026-67422

## What is CVE-2026-67422?

CVE-2026-67422 is a high-severity denial of service vulnerability in facelessuser pymdown-extensions, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pymdown-extensions is a collection of extensions for the Python Markdown library. In versions up to and including 11.0, four inline processors (caret, tilde, betterem, and magiclink) use regular expressions whose content groups can partition a run of delimiter characters in exponentially many ways, causing catastrophic backtracking. As a result, a single untrusted Markdown line under 50 bytes rendered with markdown.markdown() in each extension's default configuration drives the rendering thread into unbounded CPU usage that grows exponentially with input length, enabling an unauthenticated remote attacker who can submit Markdown to cause denial of service. The exposure is concrete for web applications that render user-supplied Markdown (comments, wikis, issue bodies, live preview), including any app using pymdownx.extra which bundles the vulnerable betterem default, as well as hosted docs/CI systems that build untrusted Markdown. The issue has been fixed in version 11.0.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-67422?

3 open source packages ship an affected version, including pymdown-extensions.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pymdown-extensions` | PyPI | All versions | 11.0.1 |
| `pymdown-extensions` | PyPI | All versions | 11.0.1 |
| `pymdown-extensions` | PyPI | All versions | 11.0.1 |

## How do I fix CVE-2026-67422?

Upgrade pymdown-extensions to 11.0.1 or later.

## Is CVE-2026-67422 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67422 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67422 and fix it if it is affected.

What it is: CVE-2026-67422 is a high-severity denial of service vulnerability in facelessuser pymdown-extensions, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67422 exists.

Affected packages and fixed versions:
- pymdown-extensions (PyPI): affected all versions; fixed in 11.0.1
- pymdown-extensions (PyPI): affected all versions; fixed in 11.0.1
- pymdown-extensions (PyPI): affected all versions; fixed in 11.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67422/ (Markdown: https://insights.sbomify.com/CVE-2026-67422/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67422
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67422
- OSV: https://osv.dev/vulnerability/CVE-2026-67422

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67422/
Summaries are generated and may contain mistakes; the official description above is the record.
