# CVE-2026-67424: Flyto2 Core: Guarded HTTP modules follow redirects into internal space without per-hop SSRF revalidation

> Attackers can exploit redirect handling in Flyto2 Core HTTP modules to access internal network resources and read sensitive data.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-c9hr-64h3-gxpc, PYSEC-2026-3569

## What is CVE-2026-67424?

CVE-2026-67424 is a high-severity server-side request forgery vulnerability in flytohub flyto-core, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flyto2 Core is an execution kernel for automation and AI-agent workflows. Prior to 2.26.7, the HTTP modules http.get, http.request, and http.batch in src/core/modules/atomic/http/get.py, src/core/modules/atomic/http/request.py, and src/core/modules/atomic/http/batch.py validate only the initial URL, then follow redirects with allow_redirects=True and without per-hop Location revalidation, allowing a public URL to redirect into internal address space and return the internal response body. This issue is fixed in version 2.26.7.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-67424?

3 open source packages ship an affected version, including flyto-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flyto-core` | PyPI | All versions | 2.26.7 |
| `flyto-core` | PyPI | All versions | 2.26.7 |
| `flyto-core` | PyPI | All versions | 2.26.7 |

## How do I fix CVE-2026-67424?

Upgrade flyto-core to 2.26.7 or later.

## Is CVE-2026-67424 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67424 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67424 and fix it if it is affected.

What it is: CVE-2026-67424 is a high-severity server-side request forgery vulnerability in flytohub flyto-core, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67424 exists.

Affected packages and fixed versions:
- flyto-core (PyPI): affected all versions; fixed in 2.26.7
- flyto-core (PyPI): affected all versions; fixed in 2.26.7
- flyto-core (PyPI): affected all versions; fixed in 2.26.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67424/ (Markdown: https://insights.sbomify.com/CVE-2026-67424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67424
- OSV: https://osv.dev/vulnerability/CVE-2026-67424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67424/
Summaries are generated and may contain mistakes; the official description above is the record.
