{"answers":{"affected":"3 open source packages ship an affected version, including flyto-core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67427 exists.","fix":"Upgrade flyto-core to 2.26.7 or later.","what":"CVE-2026-67427 is a high-severity vulnerability in flytohub flyto-core, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-67427 and fix it if it is affected.\n\nWhat it is: CVE-2026-67427 is a high-severity vulnerability in flytohub flyto-core, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67427 exists.\n\nAffected packages and fixed versions:\n- flyto-core (PyPI): affected all versions; fixed in 2.26.7\n- flyto-core (PyPI): affected all versions; fixed in 2.26.7\n- flyto-core (PyPI): affected all versions; fixed in 2.26.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-67427/ (Markdown: https://insights.sbomify.com/CVE-2026-67427/index.md)","id":"CVE-2026-67427","markdown":"https://insights.sbomify.com/CVE-2026-67427/index.md","name":"CVE-2026-67427","record":{"aliases":["GHSA-hr7p-wg7r-hg9m","PYSEC-2026-3570"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Flyto2 Core","requires_auth":"none","summary":"Attackers can exfiltrate host environment secrets via workflow parameters, bypassing capability policy denylists in Flyto2 Core.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"},{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Flyto2 Core is an execution kernel for automation and AI-agent workflows. Prior to 2.26.6, the workflow engine variable resolver expands ${env.VAR} for any host environment variable without an allowlist or capability policy check, allowing a workflow parameter to bypass the default capability policy denylist for env.get and env.load_dotenv and exfiltrate secrets through allowed modules. This issue is fixed in version 2.26.6.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flyto2 Core: ${env.VAR} interpolation reads any env secret despite env.get being denylisted","id":"CVE-2026-67427","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Flyto2 Core: Multiple HTTP-family modules fetch client-controlled URLs without the SSRF guard their siblings apply (SSRF to internal/metadata)","id":"CVE-2026-67428"},"packages":[{"ecosystem":"PyPI","fixed":["2.26.7"],"introduced":["0"],"last_affected":[],"package":"flyto-core","purl":null,"source":"GHSA-hr7p-wg7r-hg9m"},{"ecosystem":"PyPI","fixed":["2.26.7"],"introduced":["0"],"last_affected":[],"package":"flyto-core","purl":"pkg:pypi/flyto-core","source":"GHSA-hr7p-wg7r-hg9m"},{"ecosystem":"PyPI","fixed":["2.26.7"],"introduced":["0"],"last_affected":[],"package":"flyto-core","purl":"pkg:pypi/flyto-core","source":"PYSEC-2026-3570"}],"prev":{"headline":"Flyto2 Core: Unauthenticated flyto-verification /run: callback_url SSRF and internal runner-secret exfiltration","id":"CVE-2026-67426"},"products":["flyto-core"],"published":"2026-07-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-30","vendors":["flytohub"]},"summary":"Attackers can exfiltrate host environment secrets via workflow parameters, bypassing capability policy denylists in Flyto2 Core.","url":"https://insights.sbomify.com/CVE-2026-67427/"}