# CVE-2026-67427: Flyto2 Core: ${env.VAR} interpolation reads any env secret despite env.get being denylisted

> Attackers can exfiltrate host environment secrets via workflow parameters, bypassing capability policy denylists in Flyto2 Core.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 30 Jul 2026
- **Also known as:** GHSA-hr7p-wg7r-hg9m, PYSEC-2026-3570

## What is CVE-2026-67427?

CVE-2026-67427 is a high-severity vulnerability in flytohub flyto-core, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flyto2 Core is an execution kernel for automation and AI-agent workflows. Prior to 2.26.6, the workflow engine variable resolver expands ${env.VAR} for any host environment variable without an allowlist or capability policy check, allowing a workflow parameter to bypass the default capability policy denylist for env.get and env.load_dotenv and exfiltrate secrets through allowed modules. This issue is fixed in version 2.26.6.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-668 (Exposure of Resource to Wrong Sphere), CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2026-67427?

3 open source packages ship an affected version, including flyto-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flyto-core` | PyPI | All versions | 2.26.7 |
| `flyto-core` | PyPI | All versions | 2.26.7 |
| `flyto-core` | PyPI | All versions | 2.26.7 |

## How do I fix CVE-2026-67427?

Upgrade flyto-core to 2.26.7 or later.

## Is CVE-2026-67427 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67427 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67427 and fix it if it is affected.

What it is: CVE-2026-67427 is a high-severity vulnerability in flytohub flyto-core, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67427 exists.

Affected packages and fixed versions:
- flyto-core (PyPI): affected all versions; fixed in 2.26.7
- flyto-core (PyPI): affected all versions; fixed in 2.26.7
- flyto-core (PyPI): affected all versions; fixed in 2.26.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67427/ (Markdown: https://insights.sbomify.com/CVE-2026-67427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67427
- OSV: https://osv.dev/vulnerability/CVE-2026-67427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67427/
Summaries are generated and may contain mistakes; the official description above is the record.
