# CVE-2026-67428: Flyto2 Core: Multiple HTTP-family modules fetch client-controlled URLs without the SSRF guard their siblings apply (SSRF to internal/metadata)

> Attackers can exploit missing SSRF guards in HTTP modules to access internal or metadata endpoints via caller-controlled URLs.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 30 Jul 2026
- **Also known as:** GHSA-pgwh-4jj4-qm8v, PYSEC-2026-3572

## What is CVE-2026-67428?

CVE-2026-67428 is a high-severity server-side request forgery vulnerability in flytohub flyto-core, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flyto2 Core is an execution kernel for automation and AI-agent workflows. Prior to 2.26.7, HTTP-emitting modules including src/core/modules/third_party/developer/http/requests.py, core.api.http_get, core.api.http_post, graphql.query, graphql.mutation, monitor.http_check, communication.slack_send, notification.discord.send_message, notification.slack.send_message, notification.teams.send_message, ai.vision_analyze, verify.visual_diff, browser.proxy_rotate, and the agent and llm inline base_url branch fetch caller-controlled URLs without validate_url_with_env_config, allowing SSRF to internal or metadata endpoints. This issue is fixed in version 2.26.7.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-67428?

3 open source packages ship an affected version, including flyto-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flyto-core` | PyPI | All versions | 2.26.7 |
| `flyto-core` | PyPI | All versions | 2.26.7 |
| `flyto-core` | PyPI | All versions | 2.26.7 |

## How do I fix CVE-2026-67428?

Upgrade flyto-core to 2.26.7 or later.

## Is CVE-2026-67428 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67428 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67428 and fix it if it is affected.

What it is: CVE-2026-67428 is a high-severity server-side request forgery vulnerability in flytohub flyto-core, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67428 exists.

Affected packages and fixed versions:
- flyto-core (PyPI): affected all versions; fixed in 2.26.7
- flyto-core (PyPI): affected all versions; fixed in 2.26.7
- flyto-core (PyPI): affected all versions; fixed in 2.26.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67428/ (Markdown: https://insights.sbomify.com/CVE-2026-67428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67428
- OSV: https://osv.dev/vulnerability/CVE-2026-67428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67428/
Summaries are generated and may contain mistakes; the official description above is the record.
