# CVE-2026-67429: Flyto2 Core: Arbitrary file write via image.download (and other file-writing modules)

> Attackers can write arbitrary files to the filesystem via image.download due to missing path validation, potentially leading to code execution.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-2956-977x-2w3r, PYSEC-2026-3568

## What is CVE-2026-67429?

CVE-2026-67429 is a critical path traversal vulnerability in flytohub flyto-core, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flyto2 Core is an execution kernel for automation and AI-agent workflows. Prior to 2.26.6, image.download and related file-writing modules use caller-controlled output_dir instead of validate_path_with_env_config and its FLYTO_SANDBOX_DIR confinement, allowing attacker-controlled response bytes to be written to arbitrary filesystem paths the process can access. This issue is fixed in version 2.26.6.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-67429?

3 open source packages ship an affected version, including flyto-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flyto-core` | PyPI | All versions | 2.26.7 |
| `flyto-core` | PyPI | All versions | 2.26.7 |
| `flyto-core` | PyPI | All versions | 2.26.7 |

## How do I fix CVE-2026-67429?

Upgrade flyto-core to 2.26.7 or later.

## Is CVE-2026-67429 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67429 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67429 and fix it if it is affected.

What it is: CVE-2026-67429 is a critical path traversal vulnerability in flytohub flyto-core, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67429 exists.

Affected packages and fixed versions:
- flyto-core (PyPI): affected all versions; fixed in 2.26.7
- flyto-core (PyPI): affected all versions; fixed in 2.26.7
- flyto-core (PyPI): affected all versions; fixed in 2.26.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67429/ (Markdown: https://insights.sbomify.com/CVE-2026-67429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67429
- OSV: https://osv.dev/vulnerability/CVE-2026-67429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67429/
Summaries are generated and may contain mistakes; the official description above is the record.
