# CVE-2026-67550: re2: Out-of-bounds heap read in `exec`/`test`/`match` via attacker-influenced `lastIndex` on a non-ASCII subject → uncatchable process crash (DoS)

> An attacker can cause a process crash and potential heap information disclosure by manipulating lastIndex on non-ASCII strings in the re2 library.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** CLEANSTART-2026-AX56831, DEBIAN-CVE-2026-67550, GHSA-ff84-5f28-78qj, MINI-qmwh-wxc2-cxc3, UBUNTU-CVE-2026-67550

## What is CVE-2026-67550?

CVE-2026-67550 is a medium-severity denial of service vulnerability in uhop node-re2, published on 30 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

re2 provides Node.js bindings for Google's RE2 regular expression engine. Prior to 1.25.2, re2 validates lastIndex against the UTF-8 byte length of a subject but uses it as a UTF-16 code-unit offset in exec, test, match, replace, and split, allowing an attacker-influenced lastIndex on a non-ASCII subject to trigger an out-of-bounds heap read and an uncatchable process crash, with limited heap information disclosure in some cases. This issue is fixed in 1.25.2.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-67550?

2 open source packages ship an affected version, including re2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `re2` | npm | All versions | 1.25.2 |
| `re2` | npm | All versions | 1.25.2 |

## How do I fix CVE-2026-67550?

Upgrade re2 to 1.25.2 or later.

## Is CVE-2026-67550 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67550 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67550 and fix it if it is affected.

What it is: CVE-2026-67550 is a medium-severity denial of service vulnerability in uhop node-re2, published on 30 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-67550 exists.

Affected packages and fixed versions:
- re2 (npm): affected all versions; fixed in 1.25.2
- re2 (npm): affected all versions; fixed in 1.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67550/ (Markdown: https://insights.sbomify.com/CVE-2026-67550/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67550
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67550
- OSV: https://osv.dev/vulnerability/CVE-2026-67550

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67550/
Summaries are generated and may contain mistakes; the official description above is the record.
