CVE-2026-67587 Apache Airflow: DAG-author remote code execution on the Scheduler via a Serde `Callback` deserialization gadget

High 8.8 Published Updated

A DAG author can achieve remote code execution on the Apache Airflow Scheduler by exploiting a deserialization gadget in the Task SDK.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-67587?

CVE-2026-67587 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Airflow's Task SDK rebuilt a `Callback` object from serialized data by re-running its constructor, which imports the module named by the stored callback path. Because `SyncCallback` is itself an Airflow class it passes the default `allowed_deserialization_classes` allow-list, so tightening that setting does not help. A Dag author — who controls a task instance's `next_kwargs` through the task execution API — can therefore cause an arbitrary module to be imported inside the scheduler process, when the scheduler's `awaiting_input` timeout sweep deserializes that value. No non-default configuration is required; the sweep runs unconditionally. Versions before 3.3.0 are not affected: the class existed, but the scheduler sweep that reaches it did not. This is a separate code path from CVE-2026-58076 and CVE-2026-67260, which cover different gadgets reaching deserialization — applying either of those fixes does not address this one. Users are advised to upgrade to apache-airflow 3.3.1 or later.

Weakness: CWE-502

Which versions are affected by CVE-2026-67587?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 3.3.03.3.1
apache-airflow PyPIFrom 3.3.03.3.1
apache-airflow PyPIFrom 3.3.03.3.1
airflow BitnamiFrom 3.3.03.3.1

Products include Apache Airflow.

How do I fix CVE-2026-67587?

Upgrade apache-airflow to 3.3.1 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-67587 being exploited?

There is no known exploitation of CVE-2026-67587 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-67587, GHSA-2qjv-p2gc-mjg2, MINI-j8jm-4p84-qvfx, PYSEC-2026-3708.

Is CVE-2026-67587 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free