CVE-2026-67590 Apache Qpid ProtonJ2: Unbounded type nesting can lead to pre-authentication stackoverflow

High 7.5 Published Updated

A pre-authentication attacker can cause a denial of service via unbounded type nesting in Apache Qpid ProtonJ2.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-67590?

CVE-2026-67590 is a high-severity denial of service vulnerability in Apache Qpid ProtonJ2, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.

This issue affects Apache Qpid ProtonJ2: through 1.1.0.

Users are recommended to upgrade to version 1.2.0, which fixes the issue.

Weakness: CWE-674

Which versions are affected by CVE-2026-67590?

It affects 1 product.

Products include Apache Qpid Protonj2.

How do I fix CVE-2026-67590?

No fix has been published for CVE-2026-67590 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-67590 being exploited?

There is no known exploitation of CVE-2026-67590 in the wild and no public exploit code.

Sources

Also known as GHSA-hgf5-hpf4-qmrr, UBUNTU-CVE-2026-67590.

Is CVE-2026-67590 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free