# CVE-2026-67590: Apache Qpid ProtonJ2: Unbounded type nesting can lead to pre-authentication stackoverflow

> A pre-authentication attacker can cause a denial of service via unbounded type nesting in Apache Qpid ProtonJ2.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Aug 2026
- **Updated:** 6 Aug 2026
- **Also known as:** GHSA-hgf5-hpf4-qmrr, UBUNTU-CVE-2026-67590

## What is CVE-2026-67590?

CVE-2026-67590 is a high-severity denial of service vulnerability in Apache Qpid ProtonJ2, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.

This issue affects Apache Qpid ProtonJ2: through 1.1.0.

Users are recommended to upgrade to version 1.2.0, which fixes the issue.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-67590?

It affects 1 product.


Products: Apache Qpid Protonj2.

## How do I fix CVE-2026-67590?

No fix has been published for CVE-2026-67590 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-67590 being exploited?

There is no known exploitation of CVE-2026-67590 in the wild and no public exploit code.

## Other vulnerabilities in Apache Qpid ProtonJ2

- [CVE-2026-67588](https://insights.sbomify.com/CVE-2026-67588/): Apache Qpid ProtonJ2: Unbounded symbol value caching can lead to pre-authentication resource exhaustion (high 7.5)
- [CVE-2026-67589](https://insights.sbomify.com/CVE-2026-67589/): Apache Qpid ProtonJ2: Type size/count handling can lead to excessive allocation pre-authentication (high 7.5)
- [CVE-2026-67592](https://insights.sbomify.com/CVE-2026-67592/): Apache Qpid ProtonJ2: Unable to govern the maximum number of transfer frames per incoming delivery (high 7.5)
- [CVE-2026-67591](https://insights.sbomify.com/CVE-2026-67591/): Apache Qpid ProtonJ2: Incoming session flow control window can be exceeded (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-67590 and fix it if it is affected.

What it is: CVE-2026-67590 is a high-severity denial of service vulnerability in Apache Qpid ProtonJ2, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-67590 in the wild and no public exploit code.

Affected product: Apache Qpid ProtonJ2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-67590/ (Markdown: https://insights.sbomify.com/CVE-2026-67590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-67590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-67590
- OSV: https://osv.dev/vulnerability/CVE-2026-67590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-67590/
Summaries are generated and may contain mistakes; the official description above is the record.
