CVE-2026-67591 Apache Qpid ProtonJ2: Incoming session flow control window can be exceeded

Medium 6.5 Published Updated

An authenticated attacker can exceed session flow control windows in Apache Qpid ProtonJ2, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-67591?

CVE-2026-67591 is a medium-severity denial of service vulnerability in Apache Qpid ProtonJ2, published on 5 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authenticated attacker could exceed the session flow control incoming window potentially leading to denial of service.

This issue affects Apache Qpid ProtonJ2: through 1.1.0.

Users are recommended to upgrade to version 1.2.0, which fixes the issue.

Weakness: CWE-770

Which versions are affected by CVE-2026-67591?

It affects 1 product.

Products include Apache Qpid Protonj2.

How do I fix CVE-2026-67591?

No fix has been published for CVE-2026-67591 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-67591 being exploited?

There is no known exploitation of CVE-2026-67591 in the wild and no public exploit code.

Sources

Also known as GHSA-xcxh-hgpq-crj6, UBUNTU-CVE-2026-67591.

Is CVE-2026-67591 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free