CVE-2026-67592 Apache Qpid ProtonJ2: Unable to govern the maximum number of transfer frames per incoming delivery

High 7.5 Published Updated

An authenticated attacker can cause excessive resource usage and denial of service by sending uncontrolled transfer frames in Apache Qpid ProtonJ2.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-67592?

CVE-2026-67592 is a high-severity denial of service vulnerability in Apache Qpid ProtonJ2, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

It was not possible to govern the maximum number of transfer frames per incoming delivery, enabling an authenticated attacker to cause excessive resource usage and potential denial of service.

This issue affects Apache Qpid ProtonJ2: through 1.1.0.

Users are recommended to upgrade to version 1.2.0, which fixes the issue

Weakness: CWE-770

Which versions are affected by CVE-2026-67592?

It affects 1 product.

Products include Apache Qpid Protonj2.

How do I fix CVE-2026-67592?

No fix has been published for CVE-2026-67592 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-67592 being exploited?

There is no known exploitation of CVE-2026-67592 in the wild and no public exploit code.

Sources

Also known as GHSA-4gqp-3m3h-rrx3, UBUNTU-CVE-2026-67592.

Is CVE-2026-67592 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free