# CVE-2026-6790: Eclipse Jetty: HTTP Authority/Host mismatch

> Attackers can bypass security controls or poison logs by sending mismatched Host headers, affecting Jetty server deployments.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** CLEANSTART-2026-BB15937, CLEANSTART-2026-BG17653, CLEANSTART-2026-BZ08231, CLEANSTART-2026-FJ86394, CLEANSTART-2026-JF82480, CLEANSTART-2026-JT86822, CLEANSTART-2026-PQ26679, CLEANSTART-2026-UQ11500, CLEANSTART-2026-WX23354, CLEANSTART-2026-ZE47134, CLSA-2026-1779065208, CLSA-2026-1779065209, CLSA-2026-1785291679, CLSA-2026-1786441499, CLSA-2026-1786441655, CLSA-2026-1786467443, CLSA-2026-1786482291, CLSA-2026-1787658666, DEBIAN-CVE-2026-6790, ECHO-41a4-c9d8-98b0, GHSA-7p3p-8qv8-m2vh, MINI-2mxw-mr6h-mxrr, MINI-2vqx-hfq6-3hrf, MINI-3768-675p-766g, MINI-37cr-2hx4-367c, MINI-423g-79rf-4xj2, MINI-43ph-688w-4fp9, MINI-5443-vfw2-2x3w, MINI-59jj-wggv-93rw, MINI-5f32-2gh7-3cv8, MINI-5rjg-3g55-43hq, MINI-63rp-cgr4-jvx4, MINI-746j-qv3x-8qp7, MINI-7pxf-7929-gwwp, MINI-82vg-wp48-334v, MINI-88x3-r3qv-gc72, MINI-8c52-8439-qq44, MINI-98j3-6fcx-c3xp, MINI-9jhx-p8g9-38g2, MINI-9mrv-8w3v-ph3q, MINI-9w28-vg6x-fp8v, MINI-cj4q-qg8x-g7rf, MINI-cj5g-3455-ppmh, MINI-cr7m-4xxr-xfcj, MINI-cvc7-x5x5-2m3p, MINI-cwhf-f5qh-gwm3, MINI-fhfj-jjcw-hqq7, MINI-g74g-mhq5-cm8w, MINI-gjg4-fvhm-mwfx, MINI-hhr3-wgvp-563v, MINI-hvr3-2c64-p342, MINI-hvww-7343-f86g, MINI-jfrg-q9gx-3xp9, MINI-jxp4-9wj9-qj88, MINI-mgwr-cpwf-fj8f, MINI-mrp4-mjmr-jq8x, MINI-mv3x-3394-2g4q, MINI-mwh8-24w6-rm59, MINI-mxg2-5fqf-7c2q, MINI-q3wc-2jgp-g376, MINI-q8p7-h5hx-vfxp, MINI-q8q2-35m9-h3rw, MINI-qm28-x43g-cv28, MINI-qp2m-5jvf-mp9q, MINI-r2cg-9mfc-fhf8, MINI-rjxf-m767-p3xw, MINI-v2f7-cwq2-f6qv, MINI-v52v-cr3r-p898, MINI-vp5j-m82m-r893, MINI-vv2j-297p-677h, MINI-w5c7-3fcf-pj72, MINI-w5vg-j65c-6779, MINI-w84h-frjr-cxqg, MINI-wjq3-x3p7-rjx2, MINI-wq9p-qh22-x65h, MINI-wxcr-mxhj-c5cm, MINI-x5vw-9mgw-g5hg, MINI-x7rw-gfh6-xwrw, MINI-xc8x-f5pg-2vx9, UBUNTU-CVE-2026-6790

## What is CVE-2026-6790?

CVE-2026-6790 is a medium-severity vulnerability in Eclipse Jetty, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Eclipse Jetty, for HTTP/1, HTTP/2 and HTTP/3 requests, there is no strict check that the request authority (host and port) matches what provided in the Host header (if present).

This was not enforced in earlier HTTP RFC (for example, in RFC 2616), but it is in the latest RFC (9110 and 9112).

This mismatch can cause a number of problems that may be classified as vulnerabilities such as:

  *  
        
      URI constructions (for example, for redirects -- this is typical for login pages)

  *  
        
      Virtual host selection

  *  
        
      Reverse proxying

  *  
        
      Misleading logs

  *  
        
      Etc.

Given that the latest RFCs require that request authority and Host header must match, Jetty should enforce this invariant.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-6790?

10 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | From 10.0.0 to 10.0.26 | None |
| `org.eclipse.jetty:jetty-server` | Maven | From 10.0.0 to 10.0.26 | None |
| `org.eclipse.jetty:jetty-server` | Maven | From 11.0.0 to 11.0.26 | None |
| `org.eclipse.jetty:jetty-server` | Maven | From 11.0.0 to 11.0.26 | None |
| `org.eclipse.jetty:jetty-server` | Maven | From 12.0.0 | 12.0.35 |
| `org.eclipse.jetty:jetty-server` | Maven | From 12.0.0 | 12.0.35 |
| `org.eclipse.jetty:jetty-server` | Maven | From 12.1.0 | 12.1.9 |
| `org.eclipse.jetty:jetty-server` | Maven | From 12.1.0 | 12.1.9 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0.v20161208 to 9.4.58.v20250814 | None |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0.v20161208 to 9.4.58.v20250814 | None |

Products: Eclipse Jetty.

## How do I fix CVE-2026-6790?

Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 12.0.35 or 12.1.9.

## Is CVE-2026-6790 being exploited?

There is no known exploitation of CVE-2026-6790 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Jetty

- [CVE-2016-4800](https://insights.sbomify.com/CVE-2016-4800/): Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request (critical 9.8)
- [CVE-2019-17638](https://insights.sbomify.com/CVE-2019-17638/): Operation on a Resource after Expiration or Release in Jetty Server (critical 9.4)
- [CVE-2018-12538](https://insights.sbomify.com/CVE-2018-12538/): Access and integrity issue within Eclipse Jetty (high 8.8)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6790 and fix it if it is affected.

What it is: CVE-2026-6790 is a medium-severity vulnerability in Eclipse Jetty, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6790 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected from 10.0.0 up to 10.0.26; no fix listed
- org.eclipse.jetty:jetty-server (Maven): affected from 10.0.0 up to 10.0.26; no fix listed
- org.eclipse.jetty:jetty-server (Maven): affected from 11.0.0 up to 11.0.26; no fix listed
- org.eclipse.jetty:jetty-server (Maven): affected from 11.0.0 up to 11.0.26; no fix listed
- org.eclipse.jetty:jetty-server (Maven): affected from 12.0.0; fixed in 12.0.35
- org.eclipse.jetty:jetty-server (Maven): affected from 12.0.0; fixed in 12.0.35
- org.eclipse.jetty:jetty-server (Maven): affected from 12.1.0; fixed in 12.1.9
- org.eclipse.jetty:jetty-server (Maven): affected from 12.1.0; fixed in 12.1.9
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0.v20161208 up to 9.4.58.v20250814; no fix listed
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0.v20161208 up to 9.4.58.v20250814; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6790/ (Markdown: https://insights.sbomify.com/CVE-2026-6790/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6790
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6790
- OSV: https://osv.dev/vulnerability/CVE-2026-6790

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6790/
Summaries are generated and may contain mistakes; the official description above is the record.
