CVE-2026-68060 Apache Qpid Broker-J: Type size/count handling can lead to excessive allocation pre-authentication

High 7.5 Published Updated

Pre-authentication attackers can cause denial of service via excessive memory allocation in Apache Qpid Broker-J.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-68060?

CVE-2026-68060 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A pre-authentication attacker could leverage type size/count handling to cause excessive allocation leading to potential denial of service.

This issue affects Apache Qpid Broker-J: through 10.0.1.

Users are recommended to upgrade to version 10.1.0, which fixes the issue.

Weakness: CWE-770

Which versions are affected by CVE-2026-68060?

It affects 1 product.

Products include Apache Qpid Broker-J.

How do I fix CVE-2026-68060?

No fix has been published for CVE-2026-68060 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-68060 being exploited?

There is no known exploitation of CVE-2026-68060 in the wild and no public exploit code.

Sources

Also known as GHSA-x379-jmr7-h8qf.

Is CVE-2026-68060 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free