# CVE-2026-68076: Apache Airflow: Connections test API: team-scope guard bypass resolves another team's environment Connection

> Authenticated users in multi-team mode can bypass team-scope guards to use another team's credentials for outbound connections, requiring specific configuration settings.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-68076, CLEANSTART-2026-ZG38480, ECHO-2223-8553-90e2, GHSA-75mg-c62r-v95g, MINI-c7j2-mr93-xf2f, MINI-x3gj-38m3-874j, PYSEC-2026-3709

## What is CVE-2026-68076?

CVE-2026-68076 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's environment-variable secrets backend resolved a team-scoped Connection or Variable from the wrong team's scope. The guard meant to prevent this only ran when no team scope was supplied, and its pattern could not match a team name containing an underscore, which team names are allowed to contain. When the guard did not apply, the lookup fell through to an unconditional global read that resolved the stored `AIRFLOW_CONN__<TEAM>___<ID>` variable regardless of which team asked. In multi-team mode an authenticated user of one team could therefore have `POST /api/v2/connections/test` resolve another team's Connection and authenticate outward with that team's credentials; the endpoint uses the credentials rather than returning them. Exploitation requires `[core] multi_team` enabled, `[core] test_connection` set to `Enabled` (it ships `Disabled`), team-scoped secrets provisioned as environment variables in the API-server process, and knowledge of the encoded identifier. Redirecting the test at an attacker-controlled host is separately blocked. Users are advised to upgrade to apache-airflow 3.3.1 or later.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-68076?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `apache-airflow` | PyPI | All versions | 3.3.1 |
| `airflow` | Bitnami | All versions | 3.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-68076?

Upgrade apache-airflow to 3.3.1 or later.

## Is CVE-2026-68076 being exploited?

There is no known exploitation of CVE-2026-68076 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-68076 and fix it if it is affected.

What it is: CVE-2026-68076 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-68076 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- apache-airflow (PyPI): affected all versions; fixed in 3.3.1
- airflow (Bitnami): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-68076/ (Markdown: https://insights.sbomify.com/CVE-2026-68076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-68076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-68076
- OSV: https://osv.dev/vulnerability/CVE-2026-68076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-68076/
Summaries are generated and may contain mistakes; the official description above is the record.
