CVE-2026-68077 Apache Qpid Broker-J: Unbounded disposition range handling can lead to denial of service
An authenticated attacker can cause denial of service in Apache Qpid Broker-J by sending crafted disposition frames with large ranges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-68077?
CVE-2026-68077 is a medium-severity denial of service vulnerability in Apache Qpid Broker-J, published on 5 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An authenticated attacker can craft a disposition frame with large or illegal ranges causing excessive CPU usage due to naive range handling, leading to denial of service.
This issue affects Apache Qpid Broker-J: through 10.0.1.
Users are recommended to upgrade to version 10.1.0, which fixes the issue.
Weakness: CWE-606
Which versions are affected by CVE-2026-68077?
It affects 1 product.
Products include Apache Qpid Broker-J.
How do I fix CVE-2026-68077?
No fix has been published for CVE-2026-68077 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-68077 being exploited?
There is no known exploitation of CVE-2026-68077 in the wild and no public exploit code.
Other vulnerabilities in Apache Qpid Broker-J
- CVE-2026-92609 Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication
- CVE-2017-15702 Apache Qpid Broker vulnerable to authentication port spoofing
- CVE-2016-4432 AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication
- CVE-2026-92550 Denial of service in Apache Qpid Broker-J
- CVE-2026-92560 Denial of service in Apache Qpid Broker-J
Sources
Also known as GHSA-4j92-6h2x-83rf.