CVE-2026-68080 Apache Qpid Broker-J: Unbounded echo flow responses can lead to denial of service
- Exploited in the wild
- Not known
- Fix
- None listed
What is CVE-2026-68080?
CVE-2026-68080 is a medium-severity vulnerability in Apache Qpid Broker-J, published on 5 Aug 2026.
Official description
It was not possible to govern the rate at which the broker would respond to an echo flow, enabling an authenticated attacker to cause excessive resource usage and potential denial of service.
This issue affects Apache Qpid Broker-J: through 10.0.1.
Users are recommended to upgrade to version 10.1.0, which fixes the issue.
Weakness: CWE-406
Which versions are affected by CVE-2026-68080?
It affects 1 product.
Products include Apache Qpid Broker-J.
How do I fix CVE-2026-68080?
No fix has been published for CVE-2026-68080 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-68080 being exploited?
There is no known exploitation of CVE-2026-68080 in the wild and no public exploit code.
Other vulnerabilities in Apache Qpid Broker-J
- CVE-2026-92609 Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication
- CVE-2017-15702 Apache Qpid Broker vulnerable to authentication port spoofing
- CVE-2016-4432 AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication
- CVE-2026-92550 Denial of service in Apache Qpid Broker-J
- CVE-2026-92560 Denial of service in Apache Qpid Broker-J
Sources
Also known as GHSA-3jgf-c787-2jmh.